No sound after recording

I recorded from streaming music on the internet. Recorded graphics are normal and everything looks normal. When I try to play back, it scrolls along but no sound. The little stereo "speaker bands at the top are working but the microphone bands do not. (Upon recording they both work).
I have Windows 8 and Aud 2.0.2 but don’t remember which way I downloaded it.

If you record with “Playthrough” selected, then both red and green sound meters will work. You will get a recording whether or not Playthrough is selected. That just lets you hear what’s going on if you have speakers selected.

Use the little speaker pulldown to see where Audacity is trying to send the sound. Also, go into the Windows Control Panels and see if a valid sound device is selected for playback. If you use a USB microphone, it’s possible Windows is trying to send sound to the microphone. Some simple hardware drivers don’t specify whether or not they’re bidirectional.


I’ll fool around a bit BUT ------

I took the tune I “recorded” and exported as a WAV file. I then opened it with WavePad and it PLAYED!
Doesn’t it indicate that the problem may lay with my installation of Audacity?
I appreciate your further thoughts.

Doesn’t it indicate that the problem may lay with my installation of Audacity?

Right. See: pull down the speaker selector. Audacity could be trying to send the sound anywhere.

You can also get there with Edit > Preferences > Devices > Recording and Playback.

Like I said, it’s extraordinarily common to get this pathway thing scrambled if you use a USB microphone or other sound device.


I “fooled around”
a: The speaker pulldown was set for " Digital Output (S/PDIF) The OTHER two choices were:
Microsoft Sound Manager and Speakers/Headphones IDT

I have another question: The “playthrough” preferences section says "uncheck when recording stereo mix’ I don’t understand that.
I record in Stereo so should I unchek that?

Thank you

“Stereo Mix” is a special recording input setting that is available on some (but not all) Windows computers. The purpose of “Stereo Mix” (if available) is to provide an easy way to record sounds that are playing in other programs on the same computer.

“Stereo Mix” is not the same as “recording stereo”.

If you are using “Stereo Mix” as the recording input device in the Device Toolbar then “Software Playthrough” in the Transport menu should be disabled otherwise it can cause echoes or worse (feedback) effects.

Audacity thought you wanted it to send the sound to your Sony/Philips Digital Interface. S/PDIF. If you don’t have one of those, then pick one of the Windows selections.

Stereo-Mix will make your head hurt. The computer has to run the Record and Play parts of the computer at the same time for you to record YouTube. It’s a delicate act and if you mess up a setting, it’s the same as getting your rock band microphone too close to the speakers. …eeeeEEEEEE.

It’s more entertaining if your computer has natural delay. Then you can get thumping and screaming sounds, too.


You need to remember to turn those settings off if you want to do plain recording – like reading Goethe into a microphone. Or at least remember you did that before you write back complaining your microphone is broken.


I really appreciate the time and effort you are exerting in offering me help. But please look at my initial comments. I stated that I was recording streaming music from the internet, not a microphone or anything else.
I am an old hand at using Audacity in the past, love it, and never had a problem. This is just not working. PLEASE try to give me some initial settings that will work - I have tried all kinds of combinations - get terrible feedback on some and when it does record properly, there is no sound on playback. Aren’t there some default settings that I can use?
also my remark that I can play back from WavePad but not Audacity was not addressed.
Again, thank you so much for your tireless effort! I AM NOT A TECHIE! (and need simple explanations)

What are the available option in the Device Toolbar?

I think the OP said:

You want to choose the output device your speakers or headphones are connected to.

I suggest you choose “Microsoft Sound Mapper - Output”. This will always be the default Windows device, and as WavePad will almost certainly be using that default device, “Sound Mapper” should give you sound in Audacity.

If you change the Windows default playback device to something else, then “Sound Mapper” will play to that device.

If still don’t get sound playback in Audacity, reboot the computer.


Still no luck!
MY CONTROL PANEL : Recording -Stereo Mix IDT Hi Def Audio Codec//////// Playback: Speakers/Headphones IDT Hi Def Codec

AUDACITY: The only one that does not cause very loud feedback and what I can only describe as echoing is the one that records but the play back is silent although the green bands are running. That selection is: Windows Direct/ DigitalOutput S/PDIF)/ Primary Sound Capture. I’ve tried ALL the combinations!
Next I will uninstall Aud and reinstall.
Do you have a suggested download for this?
BUT still don’t understand why WavePad works fine with all the default settings (theirs and my computer)

There is no point trying all combinations. The only playback device that will work is the one you have your speakers or headphones connected to. If that correct playback device has “feedback” then that is what you have to address.

So please answer these two questions:

  1. Exactly how are you listening to playback in Wavepad? Built-in in computer speakers? Headphones plugged into the green audio out? If you have not got speakers or headphones plugged into “S/PDIF out” then you will (obviously) get no audio if you select “S/PDIF out” as playback device in Audacity.
  2. Is it recording or playback that has the feedback problem? If you import an MP3 into Audacity or do Generate > Tone, can you choose a playback device in Audacity that you can hear (with feedback)? If so, what playback device is that (exact name)?

**Note:**If this “feedback” occurs when recording “stereo mix”, all you need to do is open the “Transport” Menu in Audacity, then click on “Software Playthrough (on/off)” to turn it off.

If you do that, download this:

When you run the installer, look for the “Select Additional Tasks” screen, then put a check in the “Reset Preferences” box. Complete the installation. On launching Audacity, a dialogue will appear where you can confirm if you want to reset preferences just this once, or not. Choose the option to reset the preferences.

But I don’t think this is anything to do with the problem.


Thanks for all the help. Downloaded and re-installed. Seems to be working OK. Won’t have time to work on this for the next few weeks but so far, so good!