I’m currently running audacity 2.0.5. with my windows 8 dell laptop with serato and a SL1 box. When I try to record my mix, the only thing that gets recorded is any background noise the laptop mic picks up. I have the mic and speaker on audacity set to real tek high definition which configures to my laptop but I’mstill having issues. I’m not sure if it because my laptop only has one audio jack but whatever the issue is, I’m stumped!

Serato does not like to Play Well With Others. There have been problems before.


Are there any solutions my to my problem?

The official way to record from Serato is to buy the upgrade version that includes a record feature.

Another possible solution is to use Mixxx instead of Serato:

Is that because I’m using windows 8? My second laptop runs win 7 with serato and I don’t have any recording issues

How do you do that?
Why doesn’t it work on your Windows 8 laptop?

Its running an older version of audacity what I’m able to select “line in” and not real tek high definition to get proper recording. Also that laptop has two audio input, my laptop running Windows 8 has one.

Let me read that back to you:
Your Windows 7 laptop has a “line in”.
You want to record “Line in” on your Windows 8 laptop.
Your Windows 8 laptop does not have “Line in”.

Is that the problem?

Yes exactly!

On Win 8, can you hear the audio that you want to record in the computer speakers or headphones?

On Win 7, where is the cable coming from that you connect into the computer line-in then record from? From SL1?


No not the SL1. The setup I use for Win 7 & 8 is connecting the computer line in to the back of my mixer’s (pioneer djm-400) master out input using a rca to 3.5mm cord, but Win 8 doesn’t record anything. The mic just picks up background noise.

You said before that the Windows 8 computer does not have line in. Do you mean you only have one input on that computer? Does the Win 7 computer have mic in and line in?

As I asked, can you hear what you want to record on Windows 8?

Have you been into Windows Sound and shown and enabled disabled inputs? If not, please do so. Then you may be able to see the external mic input that you want to record from.


Yes I only have one input on the Win 8 and yes Win 7 has linebin and mic in

I can hear recordings but it isn’t coming directly from what I play on serato, it’s the background noise the mic picks up.

No I haven’t tried that. I’ll see if that works

Hello again I tried your suggestion but to no avail because the issue isn’t with an external mic or driver I’m trying to connect, the issue is the mic on my laptop (Real Tek High Def Audio) not picking up what I’m playing from Serato. I’m not sure if this new Audacity update isn’t compatible with Serato SL1 or if it’s the Dell running Win 8 but I’m totally stumped.

If you only have a pink physical mic input on the Windows 8 machine then it is no use for connecting to the mixer even if it recorded, because it would likely be distorted mono or poor quality stereo.

So assuming you can hear what you want to record in headphones or speakers that are connected to the green audio out jack on the computer, record your mixes using stereo mix/what U hear of the sound device. Can you see stereo mix as an input in Windows “Sound” after showing disabled devices?

If not, try recording computer playback using Windows WASAPI loopback recording. Please see here for how to do that: .

If none of that works, buy a USB device with a line-in or the proper version of Serato that offers recording, whichever is the cheaper.


What I want to hear/record is coming from serato through my mixer and I only have one inut/output jack on my laptop

Yes I saw the stereo mix input option

You mean that one audio port becomes an input when you connect an input to it? There is no separate output and input? Have you looked in the laptop manual to see if it’s anything other than a mic input?

What is stopping you buying a USB interface that has a line-in or the full version of Serato?

If you think the mic input is good quality, what stops you connecting the mixer to the mic input and choosing the mic input in Device Toolbar ? What input exactly are you choosing now?

If you don’t see the mic input in Audacity, right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over empty space and choose “Show Disabled Devices”. Right-click again and “Show Disconnected Devices”. Then right-click over each device and choose “Enable” if that is an option.

Restart Audacity. Do you see the mic input now in Device Toolbar?

If you want to hear what the mic input is recording, choose Transport > Software Playthrough in Audacity, then record.

If you only hear silence, are you sure you are actually sending any audio from the mixer? Connect the “CD/Tape out”, or the “Main output” or “Alt 3/4” output of the mixer to the mic input. Test it on the other computer to make sure the mixer is sending the audio you want.

If you need to hear the audio the mixer is sending without having Audacity running, right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the “mic” input (or whatever it’s called) then choose “Properties”. Then click the “Listen” tab. Check (tick) the box “Listen to this device”. Set the drop-down to send audio to your required playback device.

You can then if preferred (or if it works) record that audio using stereo mix (if you set Device Toolbar to record from stereo mix). Turn off Transport > Software Playthrough if you try this. You may or may not get feedback echoes recording in this way.