No Rhythm track under Generate

When I attempting to perform a latency test I go to Generate>Rhythm Track, there is no Rhythm Track. I had a previous hard drive with the previous edition of audacity and it was there. But my hard drive crashed, had to get a new one, therefore having to download latest release and it’s not there. Is there another way to find rhythm track?

Which version of Audacity? (look in “Help menu > About Audacity”)

Do you have Generate > Metronome? Anything like that will work.

Koz

It’s version 2.4.2
Under Generate this is all there is: Add-Remove Plugins, Noise, Tone. No Rhythm Track, no metronome.

Is that all?

Yes that’s all. That’s it. It changed with the new update. It wasn’t like that before.

Try doing “Tools menu > Reset Configuration”, then restart Audacity.

Still not there.

Did you get the “Audacity 2.4.2 installer” from here: https://www.audacityteam.org/download/windows/

Yes

I found the problem. Rhythm Track was disabled in Add/Remove Plugins. When I used Reset Configuration it did not reset it. But mystery solved! Thanks for the help!

It would seem that you have also disabled other standard plug-ins also.
You can see here which Generate plug-ins are shipped with Audacity and enabled by default: Generate Menu - Audacity Manual

If you want to reset all plug-ins back to default, you can do so be deleting the “pluginsettings.cfg” and “pluginregistry.cfg”.
By default they are in the hidden folder

C:\Users\<your-user-name>\AppData\Roaming\audacity\

Yes, I disabled all plugins I’m not using since I use Audacity for narration only. I decided to use punch and roll and needed the rhythm track to set latency. Forgot how to get it back! Duh! Sorry! :blush:

It took a few hours to figure it out, but I finally did find the solution for a click track installment:
go to what is probably your computer C drive, Program files, Audacity, plugins, Rhythm track. Copy it to desktop and use the Nyquist installer from tools in audacity to Install it, or maybe I just pasted it, but it finally got installed.
For Audacity to let you use it in the beginning of a track as a click track, go to Edit, preferences, tracks, tracks behaviors, and click “editing a clip can move other clips”.