No recording device?: Error Code "0" and 999 etc. Speaker output is working.


I have the following System:
Asrock H110M-ITX/ac and Windows 10.

I use the “Realtek High Definition Audio” output. Analog jack on the front.
But I can’t record system sounds.
I have tried:

  • Windows WASAPI
  • MME
  • Windows DirectSound

With all other options.
I get errors “0 Success” and “999”

E.g. Windows WASAPI / Speakers (Realtek High Definition Audio / 1 (Mono) Recording Channel

The speaker output in the system works.
E.g. YouTube in the browser. No problem.

There are 4 settings in the Device Toolbar
host, recording device, number of channels, playback device

To record computer playback:
“host” should be set to WASAPI
“playback device” should be set to the device that your audio plays from
“recording device” should be set to the “loopback” from the device that your audio plays from.
“number of channels” should normally be “2 (stereo)”

May I add another question here. I’d like to record my ghost box radio (audio only) with audacity as the recorder. I have my ghost box radio with a 3.5mm cable going into the headphones jack of my laptop. Was wondering what settings I need to record the ghost box radio (audio only) using audacity as the recorder?

Are you getting an error code?


My solution, “Stereo Mix” in audio options. But this was not the first attempt. I installed the last version from the englisch Audacity site (german site has only a old version), beforem, I tried it also with my installed older version…

The German “Audacity” website is fake and distributes viruses and other malware.
The only official Audacity website is here:

We also have a help forum (this forum), and a wiki (Missing features - Audacity Support) and an on-line manual for the current Audacity release (
There is a “semi-official” German forum ( which is not run by the Audacity team but by German Audacity users.