no playback through computer

My new Audio-Technica record player won’t play records through the software. I know Audacity is designed for recording, but is there any way to play it as the record plays? I tried going in to the meter toolbar and turning on monitoring. But all I get from my computer speakers is feedback.

Turn off software and hardware playthrough in Audacity and use


If you are getting feedback when you turn monitoring on in Audacity it is very likely that you have not selected your turntable as the input device but instead have the input set to the internal microphone. If you want to record (as well as listen to) your records you’ll need to select the turntable as the input device in Audacity. It is likely called “USB Audio Codec” or similar.

See the Device Toolbar page or the Devices Preferences page in the manual for instruction on setting the input device. This page on connecting USB turntables might also help.

The link Gale sent you too is the “freebies” page at the Rogue Amoeba website. The freebie you want from that page is “LineIn” which will allow you to listen to your turntable without using Audacity.
– Bill