no multichannel recording after firewire board crash

Hello all,

I am new to the forum and to the Audacity program too, so I hope I will do my best to keep things as meaningful as I can for you. I already check the FAQ questions and made a search into the forum previous topics, but I could not find something which was quite the same information that I need.

I am running Audacity 2.0.2 on Windows XP 2002 version SP3.

What I would like to do is simply recording some audio files from my 8-channel pre-amplified microphones input device Presonus Firestudio which is connected to my desktop PC trough a Firewire port. The port is not properly fixed to the main board, so every now and then I get a blue screen saying a driver is not properly connected and not properly working which makes me often restart the recordings :frowning: .

Anyway, it is been some time since I have been recording without any problems (other than stopping for the Firewire board crash), but this morning something unpredictable happened! Basically, while so far I could normally record in any possible configuration the signals coming from my 8 microphones now, after the n-th crash, Audacity does not recognise my 8 inputs anymore, but one only. I tried to understand whether it is a soundcard problem, but if I run the software which comes with it, it can still work fine and see all the microphones, their input levels and so on. I also reconfigurated all the Audacity options for the input device, but still nothing changed. I unplugged all the possible things, restarted all the devices and made all kind of switch off and on again operations, still Audacity sees one input only.

What do you think has happended? And where do you think I may be wrong?

Thanks in advance for your help,


Why don’t you connect the firewire port properly?

Have you restarted Audacity?

Which audio program now sees the eight channels, but Audacity doesn’t?

Have you redownloaded and reinstalled the control software and driver ( ) ?


Hi Gale,

Thank you for your answer.

As for the firewire it’s a long story, but I think I’m definitely buy a proper one which fits my board soon.

Regarding all the tweaks you suggested instead, I have tried everything already :frowning: , but nothing worked. The sw which can see the eight microphones instead is the control one which you mentioned (FireStudio Universal Control)!Which has still having the same configuration I setted it up the first time I used it.

Have a nice day!


Are you sure you have got Windows and Audacity settings exactly as they were, for example the Presonus is the default Windows recording device and Audacity host in Device Toolbar is Windows DirectSound? DirectSound is more likely to produce multi-channel audio than MME.

If that does not help you could try quitting Audacity and resetting Preferences but I would not be too optimistic.

You could also try a Windows system restore back to a point before Audacity stopped seeing all the inputs.



The silliest thing I couldn’t think of worked!!Thank you so much for suggesting me to restore the System!Finally I got it working again :slight_smile:

Just fyi, all the settings where exactly as you said. I really don’t know what was going on. Anyway I’m so glad I fixed it.

Thanks again,