no input source icone

hi
I have audacity 1.2.6 with Ubuntu 7.04 feisty

on the mixer toolbar, there is the tow volume levels but there is not the input source
i can’t choose the input source !

You need to go through the edit → preferences → audio i/o menu. Using the menu on the main screen requires your audio drivers to be written a specific way, many users have to use this method.