No input device

Ive had this problem ever since a computer crash a few months back, after wiping out my hard drive I reinstaled everything including Audacity. Im using windows 7 64 bit, my pc is an HP pavilion 4316, AMD athlon quad core, 6GB DDR3 system memory, 1 terabyte hard drive. The problem is I can not record, there is no level screen just a gray box. If I click record I get the message “no input device”. I have tryed the FAQ’s and followed instructions but can not find any input device to add. I tryed
Rt clicking the speaker icon & choose “recording devices”, everything in there is connected or enabled. Ive had it with this, it’s been months since I’ve had Audacity. I have even tried uninstaling & reinstaling, no cigar! Can anyone help? Please in layman terms? >>>>computer stupid<<<<<< :blush:

See here for how to access the recording settings in Windows:
Could you post a screen shot of those recording settings so that we can see what your computer is doing.

Thats what Im talk’n about! Thanks Steve, I didn’t know to right click in the box. The box was only showing 2 items Mic & Line in, right clicking gave me another choice and that restored the level meter’s. Now I will test it, if it doesnt work I will post.

I am having the same problem. I dont see the audio i/q in the preferences. How do I select the device as USB to connect my mixer. Could someone help

I presume that you mean the “Audio Devices I/O”?
That has not been in Audacity for years. I think the last version to have that screen was Audacity 1.2.6.
The current version of Audacity is 2.0
In Audacity 2.0, use the Device Toolbar to select the Recording/Playback input/output

Thankyou for the reply. Could you tell me why the USB input option is not available at the drop down box to select . I have connected my alesis multimix 8 USB FX mixer now.What I am seeing now is [ Microphone Realteck and Microsoft sound mapper ]
I dont see the -USB input- to select .Am I doing something wrong.Thanks

Normally one would connect USB devices before launching Audacity.
If you connected the USB device after starting Audacity, click on “Rescan Audio Devices” in the “Transport” menu.

Thankyou Steve-I tried both Did not work. Still unable to see the USB option to select. Any other remedies ? Thanks

Ok doing this gave me the screen back that shows something is recording/playing, however pressing record still does not work. Im using a streaming radio station to record.

Steve, Im sorry Recordist is having a similar problem, however the responce’s to his problem are not helping my problem, it’s confusing, shouldn’t we stick to my problem being this is my tread? Im not upset or anything just confused.

If you see anything useful in this conversation with TinPan please try it. If you require individual attention please start a new topic.

Does your computer have an option to record “Stereo Mix”?

Audacity wont give me the option the put it on build input