no fix for unclosed token ? [SOLVED]

Is there still no fix for: unclosed token at line XXX? I noticed A file that was not there before:
aup.bak. Luckily I took your advice and exported the good stuff to wave form.But would like
to get the full project back if possible.

“unclosed token at line XXX” isn’t actually a bug - it’s a warning that that the AUP file is broken.
There have been a number of improvements to make saving projects more robust in recent versions of Audacity, but it is not possible for software to protect against all possible failures (such as hardware failure or losing power before the save is complete).

The current version of Audacity is 2.2.2 and is available via the Audacity website:

I’ll definately get the latest version,but what about the aup.bak file that now appears under
the audacity project file ?

Oh, and by the way, this was A project that had been completed (and saved) for quite some

To open a project “.bak” file, it must be in the same location as the project “_data” folder, and then you can just open it from the “File menu > Open” command.

For example, if you have file called “myProject.bak”, then you need to find the folder called “myProject_data”. Both the file and the folder must be in the same location, so you could for example, copy both “myProject.bak” and “myProject_data” to the Desktop, then from Audacity’s “File > Open” command, select the “myProject.bak” which is on the Desktop.

Both the aud project file and data file are in the same folder and labeled correctly.However,
when I click on the bak file I get: “you are trying to open an automatically created backup file.
Doing this may result in severe data loss.Please open the actual Audacity project file.”

When I click on the original Aud file I get an Audacity debug report

  • Ensure that you are using copies, not the originals
  • Ensure that you are using the latest (2.2.2) version of Audacity
  • If the filename is “something.aup.bak”, change it to “something.aup”

Good news! I was able to save it ! I took off the “aup” after the file name.
Thanks for all your help

Good news indeed :slight_smile:
I’ll mark this topic as “solved”.