No audio signal in Audacity from USB input

I’ve recently purchased a Behringer u-phoria UMC22 and trying to record audio via its USB input using my MacBook Air (2018 running Mojave).

I’ve checked that Audacity has microphone access in Privacy settings.

Via Settings-Sound I’ve selected the USB input and can see the input level is shifting up and down, so is receiving a signal.

I’ve selected the same input in Audacity and tried monitoring but hear nothing. I’ve also tried recording but no waveform is shown.

As a test, I’ve changed the input in Audacity to the internal mic. I can successfully monitor and record this input, so the problem does appear to be with the USB input.

Any idea would be appreciated!

Update: I’ve also checked the device is selected in the “Default Input” in the Audio MIDI Setup (it was set automatically before I checked it).

To potentially exclude Audacity from the mix, anyone know if it’s possible to listen to the input without Audacity? I incorrectly assumed it was possible via Settings-Sounds where I can see the input levels going up/down. Output is set to internal speakers and volume is up.

Further update: I found that it’s possible to record audio in QuickTime Player. I’ve tried that and it works fine. Therefore I presume it is a setup issue within Audacity or Audacity’s access to the device.

What are your settings in the device toolbar?

Core Audio (only option) | USB Audio CODEC | 1 (Mono) Recording Channel (only option) | MacBook Air Speakers

When you try recording something, do you see any signal on the recording meter? (

There is no signal displayed on the recording meter when monitoring or recording.

Back up a notch.

Apple (upper left) > System Preferences > Sound > Input.

The panel has the ability (unlike Audio MIDI Setup) of showing you a bouncing sound meter.

Does it bounce?


Yes, it does “bounce”. This is what it was referring to in my original post:

Via Settings-Sound I’ve selected the USB input and can see the input level is shifting up and down, so is receiving a signal.

I assume this is what you’re referring to?

I’m having the exact same issue. I purchased a Behringer PODCASTUDIO USB Complete Podcasting Kit. I’ve got everything correctly hooked up to my Mac where I’m using Audacity, input/output set to USB Audio CODEC, no matter what I do, mic does not read or record, however, it DOES light up on the USB mixer. Have you had any luck on Audacity? I’m desperate for ideas.

Can you record, as I can, using QuickTime Player?

I’ve tried using somebody else’s MacBook and it’s working fine via Audacity. Therefore it must have something to do with my setup. I haven’t had time to investigate further as yet and am away for the next three days. I hope to be able to investigate further soon. Let me know how you get on.

LulasMom - what Mac and OS are you using? I’m wondering if it matches mine (MacBook Air 2018 running Mojave). It worked fine using an earlier MBA on the same version of Mojave.

Same problem here and I went through the same routine. I bought a Behringer UCA222 and try to use it on an macbook pro late 2012. I am running Mojave 10.14.5. I can’t figure out what I’m doing wrong.

And I fixed it :slight_smile:. I turned Audacity off and on again while playing a record through the USB codec. Then the option USB audio CODEC appeared under Built-in Microphone.