No audio being recorded


I’m new so please forgive me if I miss anything.

I’ve been using Audacity for a few years and have had no issues. 5 months ago I started to hear echo and distortion when recording tracks off my PC. So Spotify and YouTube ect. I have resolved this but if I am playing a video off YouTube or sound off Spotify now I get no input waveform or recorded sound when I play it back. The record levels are showing circa -35db - 45db and are green. This may have occurred after a Windows update, I’m not to sure.

I have tried all manner of combinations with MME and WASPI ect. I have also checked input recording via windows for levels and what you hear ect

I have reset my PC Windows 10 home (64-bit operating system), updated drivers and have reinstalled the latest version of Audacity last night but still no joy

I am baffled and could just do with a little advice so I can use Audacity again

Thanks Mike :slight_smile:

WASAPI should work but you have to choose [u[/u]]( as your recording device.

FYI - It’s a copyright violation and a violation of your user agreement to steal music from Spotify or YouTube. The artist only gets paid (a very-small amount) when you stream.

My settings have failed me after a windows update.
After much tweaking, the only way I can record from whats playing on my screen is to use WASAPI and the main output from my KA6.