No association in the context menu (SOLVED)

Good morning.

Having installed the latest release, 2.0, when I position it right on a file (eg. Wave) → open with → select the executable audacity.exe

Opening the same file, Audacity does not appear in the context menu, this was not the case with the previous release.

Using Windows 7 64-bit.


Does this help?

I agree with you, but this is not the solution.

If I run the association with any other program normally isntallato, envi cdeve appear in context menu, like Audacity aveniva in release 1.3.
So the problem lies in the 2.0 release.

Well there’s been almost half a million downloads of Audacity 2.0 since it was released and we’ve not been flooded with complaints.
Perhaps you missed the step to select associating projects with Audacity during the installation, or perhaps there was a registry error that prevented the file association from being updated correctly. There’s quite a few things that could account for the problem, but given the rarity of the occurrence I don’t think that it looks like a problem with the installer. If it is all working correctly now, that’s the main thing.

In version audacity-win-unicode-1.3.14 installs a registry key that does not appear in relase 2.0.
I manually entered lachiave registry, and everything works fine.

Windows Registry Editor Version 5.00




@=""C:\Program Files (x86)\Audacity\audacity.exe" "%1""

Thanks for the update MIMMO61.
I’ll pass on the details to the developers.

Several a day is bad enough, though :slight_smile: .

It is not recommended for most users to directly edit the Windows Registry. You could damage your computer.

For the current safe solutions (rename the Audacity 2.0.0 executable to something other than “audacity.exe”, or install and run CCleaner from, see: .


1.3.14 does not install that registry key. Please look at the .iss installer files in the source code: .

What created that registry key (HKEY_CLASSES_ROOTApplicationsaudacity.exeshellopencommand) was setting an association with Audacity for a file type. The above registry key then points to 1.3.14 Beta. That fact means you cannot then set an association to 2.0.0 until you rename the 2.0.0 audacity exe to something other than “audacity.exe”, or edit that registry key to point to the 2.0.0 audacity.exe (as you did).

It is not recommended for most users to directly edit the Windows Registry. You could damage your computer.


Mine is not an invitation to enter the registry key, especially to non-experts, so if it goes to everyone assumes this responsibility.

For advanced users who want to do that there is no problem, possibly when you insert the key in the registry it can be easily removed by installing the key off that totally eliminates.

Windows Registry Editor Version 5.00



Before installing the new version Audacity_1.3.14 I had to uninstall and clean the registry with CCleaner and another Tool.

The Key reg, which I thought was not installed, is generated when making the association with the media file.

I apologize if I created a non-issue, I’ve been able to verify on two different computers.