New user, i don't know how to sync please help

I have national treasur dual audio hin eng. Eng audio is perfectly sync but hindi is out of sync at many points so please help how to sync audio

You’ll need to explain much more about what you are trying to do.

Do you mean you have an Audacity track with English spoken word, and another Audacity track with Hindi spoken word? You can press F5 on your computer keyboard then click and drag to move a track left and right. Press F1 to go back to the Selection Tool when you have finished dragging.

Please respond. If we don’t hear from you after a few days we will delete your post.


Sorry due to examination i didn’t use this for few days

I have a movie. Eng audio is default but hindi audio is from different source like dvdrip or vcr. Audio is out of sync in whole movie. I used vlc to delay the track but audio is unsync at many point. So what should i do?

And other thing is that i extract bot eng and hindi audio by any video converter from national treasure movie and open in audacity

Now when i watch this movie in vlc hindi audio is 2 or 1.5 sec earlier but in audacity it is 11 sec earlier

If you insert a different audio source, that is what is likely to happen. You should buy the DVD (if there is one) which presumably has properly synchronised sound tracks.

What you could possibly do is import the Hindi audio into Audacity and use Effect > Change Speed to make the length of the Hindi audio exactly the same length as the English audio. Then once the delay is adjusted correctly the Hindi audio should be synchronised throughout its length.


I tried to delay it take several time to process but nothing happen and bluray is not available with hindi audio so there’s no other option

And how to remove sentence from post?

If you have adjusted the delay in VLC but the audio synchronisation is correct in one part of the video but wrong elsewhere, this suggests that the Hindi audio plays at a different speed than the English audio does. You can use Effect > Change Speed to make the Hindi audio play at the same speed as the English audio does.

It will probably need only a very small percentage change. You can see the effect it has on the length by double-clicking in the track to select all of it (click above Mute/Solo to left of the blue waves if the double-click only selects a clip) then look in Selection Toolbar at the bottom of the project window.


I edited your post to correct the problem. Can you see an “Edit” button in your own posts, to left of the “Quote” button?