New track is recording playback track during overdubbing

I am running Windows X and and Audacity 2.0.3. I imported a wav file and ran a mic and preamp into the line input on the sound card.

I am trying to overdub a new vocal track with an existing track.

When I have ‘overdub’ set to on, the recording track records the playback track as well as my microphone input. This occurs relative to the Audacity output volume even if their is no analog sound for the mic to pick up. When ‘overdub’ is set to off, I can’t hear the playback track. How do I hear the the playback track, yet not have it record onto the new microphone recording track?

Thanks, Ron

Edit > Preferences > Recording: [X]Overdub … should be the only thing selected.

Audacity Device Toolbar should be pointing at your microphone or soundcard, not Stereo Mix, What-U-Hear or other “fake” software devices. If you like recording on-line YouTube sound tracks, that’s the exact setting you don’t want for overdubbing.

Device Toolbar

I don’t know what a sound card looks like (electrically) on a Windows machine. Audacity should be pointed at your soundcard for recording.

Multi-Track Overdubs


One more. We do have a thing about this.

Overdubbing with a Soundcard