New to Nyquist: Help Starting up using plug-ins [SOLVED]

Hello I have been using Audacity some time and only recently realized it has plugins.
How exciting! Except I can’t get any of them working… :frowning:

I am using Mac OS 10 and have tried plugins from different sources. The same problem with each plugin I try is it shows up in Audacity “Effect” Menu Options, but when I select the choice from the menu… nothing at all happens.

Literally nothing… no window popup, no modification of the selected sample, no new options presented to modify it?

This isn’t code I wrote myself… I’m trying to get a generic “Tremolo.ny” and a “Vibrato.ny” plugin working mostly, but so far no success to get these plugins… or any plugin working at all… it is like my new plugin menu options might as well be grayed out (but no it seems black like a real menu choice) just nothing happens.

I think I must be making a basic error, adding these plugins with a wrong method somehow.

Please help a poor newbie take the first baby steps here… these plugins look so exciting to play with :smiley:

Nothing Nyquist is working… the “Nyquist Prompt” window doesn’t appear either if i make this selection. Maybe that is an important clue to what is wrong here.

I found out I can use LADSPA plugins without difficulty… but anything Nyquist don’t work for me. I’m interested in getting a Vibrato (Vibrato plugin doesn’t seem to exist in LADSPA, and don’t know how to write it) functionality up & running somehow so I’d love to know what is wrong with my Nyquist here :question:

It doesn’t appear so. Once the plug-in appears in the menu, it means that Audacity has found it in the “Plug-Ins” folder. (You are just putting the .ny file into the “plug-Ins” folder, along with the .ny files that are already there, and not doing anything else to it?)

I’m not familiar with Macs, but it looks as though there is something else causing the problem.
What version of Audacity are you using?


If you are on OS X 10.4 or higher you should be using 1.3.14 Beta: .

From your description, you either did not drag the “nyquist” folder into the folder you are running Audacity from, or you renamed that folder, or possibly you are running Audacity from directly inside the .dmg. Correct installation instructions can be found in the link above.


thanks for the tips! turns out it was a bad install i did & after carefully reading install instructions and reinstall all plugins now work as expected!

yay! thank you :smiley: