New Limiter in 2.1.1

I’m still figuring things out, but I’m having one of those frustrating “it worked before, why did they change it?” moments.

Can anyone explain the thinking to me behind this new limiter? Specifically, why is it, ahem, “limited” to -10dB? That doesn’t work for me. Nor would I want to apply gain to the section I’m working on first, as it would then throw it out of whack with the surrounding audio.

I’m editing live recordings, and a frequent first step in my workflow is to cut back the applause at the end of a song so it’s not the loudest thing. Then I can boost/adjust the song as a whole. A blunt hard limit works fine for applause 99% of the time. In a recording I just opened, I want to run a limit on the applause to about -27dB, in line with the loudest part of the rest of the song, but I don’t see how I can do this with the new limiter.

Am I missing something obvious?

Is there a way to remove that artificial -10db limitation? Alternately, is there a way that I can simply re-enable the old Hard Limiter?

It sounds like the rest of the song is way too quiet.
What is the peak level of the applause?

I’m not sure what “too quiet” means. It’s a field recording, and it is what it is.

The applause is at about -20db.

I can understand where you’re coming from. It just means the algorithm starts from some averaged value. Now, I don’t know what average, or what the algo does, but Steve wasn’t referring to your capabilities as a recordist.

You and another two or so blokes were the only ones who really understood it this way. We hope this change will be better for the other five or so users out there… :laughing:

No, seriously. It’s a change everybody hopes will work out. If you have a problem with it, shoot. But you’ll have to provide a little more detail about the settings you used in the old system. The glass ball being out again and so…

As a work-around, try boosting the volume by 20dB, Apply limiting at -7dB, then reduce the volume by 20dB.

Or, if you simply normalize the file (for peaks at or near 0dB) before limiting, you should be able to get more reasonable results.

You can also fade-out during the applause or use the Envelope tool, etc.

I want to run a limit on the applause to about -27dB, in line with the loudest part of the rest of the song, but I don’t see how I can do this with the new limiter.

That’s an unusual requirement… A song with peaks of -27dB is way-way too quiet for normal listening.

Okay, let’s consider the file in the attached pic.

My old workflow was basically this:

  1. select the loudest section of the music, use amplify to see how much I could boost it. (Say, in this case, 17.8dB)
  2. select the spike of applause at the the end, apply hard limiter to it, giving myself a bit of extra room (I’d probably apply, say, -19dB)

Then I can work with the full track as required, and when I boost or apply effects I know the peak is the peak of the music, not the applause.

Now – again, unless I’m missing something obvious – I have to go through several extra steps to do the same thing, because the most I can apply with the limiter is -10dB. Why is that slider even there? Why should I only want to go as far as -10db? Why not simply let the user enter whatever value they want there?
2015-07-18 limiter.jpg

A song with peaks of -27dB is way-way too quiet for normal listening.

Obviously so, but this is the FIRST stage in my processing. I want the spike of applause brought down before I work with the whole file.

Tried it. It’s a bit daft to be limited that way. Is there supposed to be a “debug” button? When I click it, there’s a Nyquist error:

Maximum table size exceeded (10000) -NIL
if continued use truncated sound for table

And I can select the error text, but not copy it :unamused:

Command-w doesn’t close the error window, but CTRL-C does…

Unless you are zoomed in vertically, it does not look like the peak is anywhere near -27 dB. It looks closer to about -4 dB :confused:
I’d estimate that the peak level of the music is around -20 dB.

No extra steps required, just steps in a different order.

The new Limiter can handle peaks over 0 dB in a sensible way, provided that the track is 32-bit float format (default and highly recommended).
So, assuming that the peak level of the music is about -20 dB, amplify by +15 dB (you still have 4 dB of headroom), then apply the limiter.

Having said that, if the loudest peak in the recording is -27 dB, then you are limiting the quality of your recording by having the recording level too low. We generally recommend adjusting the recording levels for a maximum peak of around -6 dB (about 20 dB higher than you describe).

Because it is a Nyquist plug-in, and Nyquist plug-ins don’t have numeric text boxes without a slider.

I don’t know Nyquist so don’t take this as the definitive answer, but Nyquist plugins are only text files. Try changing line 21 to

;control thresh "Limit to (dB)" real "" -3 -30 0

assuming you want a minimum of -30 dB. The slider will change accordingly.

We’ve been asking ourselves that recently - previously you could enter values outside the slider range but now the values are validated according to the slider range. The validation is good, the range limitation perhaps not so.


Although it probably does not matter in your particular case, the new Limiter can provide much better sound quality than the old “Hard Limiter”.

That is a concern, but I can’t reproduce that, Can you give steps to reproduce?

You can take that as a definitive answer :slight_smile:

I found it beneficial to precede limiters and compressors with either Amplify or Normalize to put the show waveforms somewhere predictable before acting on them. In your case, it would eliminate the need to even premeasure the show sound. Amplify to default and then Limit the peaks. You know where they are because Amplify put them at 0dB, every time, and it doesn’t damage the sound. It makes threshold settings either irrelevant or fixed values.

I have been using a pre-production version of Limiter, so this may no longer work on the newer one, but it’s been handy.


There are no hard and fast rules, but that is the usual, (and generally recommended) way to use the effect.

Because the Limiter effect has up to 10 dB boost pre-limiting, it has in effect a 20 dB range (it can reduce peaks by 20 dB relative to the non-limited audio).

It’s a brand new install of 2.1.1…

Besides having the .cfg problem (prefs not being read/stored when using 2.1.0 next to 2.1.1, it all seems very stable.

I didn’t enable the debug button. In fact, it was the first time I opened the Limiter Nyquist plugin.

I’m gonna remove the .cfg and see if the button is still there. I’ll be back…

Try deleting pluginregistry.cfg and pluginsettings.cfg as well. That will cause the effects to be re-registered and should avoid conflicts with any previous version that you may have had installed.

Now I’m baffled… :open_mouth:

I seem to have no file named “Audacity.cfg” on my system. EDIT: nor pluginregistry.cfg, nor pluginsettings.cfg…

Spotlight can’t find it, locate can’t find it and I can’t find it if I look in

/Library/Application support/audacity/

There’s only a directory named “libs”, containing ffmpeg.

or in


But prefs are kept for 2.1.0 and 2.1.1…

As an experiment, I moved the audacity folder from Application support and started Audacity. No new folder gets created. Audacity complains about ffmpeg, but prefs are visibly set.

When moving back the “audacity” folder, the complaint about ffmpeg goes away, but still NO audacity.cfg…

So, where is Audacity.cfg hiding? :unamused:

I’ve created a folder “Portable Settings” and all seems to go as it should. An Audacity.cfg and a couple of folders are created in the “Portable Settings” folder.

It seems better this way.

The “audacity” folder is owned by the user. Presumably, I created it myself long time ago. Could that be what’s stopping Audacity from creating files in there? But shouldn’t Audacity be running as the user?

Could it be that case sensitive vs. case insensitive is rearing it’s ugly head again?

Also, the folder “libs” in /Library/Application Support/audacity/ contains ffmpeg, but every lib also has an alias. That alias has been created the day I installed 2.1.0. I think.

I need a beer. And a think :confused:

I’m guessing that OS X is hiding it from you, but I don’t use OS X so that’s just a blind guess :wink:

On Linux (which is case sensitive):
Portable Settings

Well Steve, as a Mac user, I have to strongly disagree. :smiling_imp:
As an average guy, tho, I’d think locate would still have to find it? Or is even the Terminal becoming completely unreliable too?

That checks out. The portable install behaves as it should.

In between, I’ve checked and then repaired permissions. Nothin’ about Audacity, or the /Library/Application Support/ folder. Or any other folder that could be remotely related. Lots of errors about What’s up Apple? And about Ruby, but those are permissions I set by hand, for testing purposes.

Complete list available on request. It’s in Dutch, tho.

Haven’t restarted yet.

Repairing disk permissions seems to have reset prefs. Audacity 2.1.1 shows the default warnings and is back to defaults. It still finds ffmpeg and lame in

/Library/Application Support/audacity/libs/

But that’s a standard location, so no worries there…

In a portable install, prefs seem to behave as should.

When using the contextual menu (ctrl-click with a file selected, as in “open with”), Audacity 2.1.0 shows as "Open with Audicity and 2.1.1 shows as Could this be vaguely related?

Need to think about this.