New install, no effects plug-ins, no choice to Add/Remove th

I’ve done a search but can’t find anything like this.

I’m using a fresh install (on fresh hard-drives) of Ubuntu 14.04-4 LTS, 64-bit.

I have the same trouble when installing from either the standard Canonical repositories, (audacity and audacity-data 2.0.5-1ubuntu3.2) or from http://ppa.launchpad.net/ubuntuhandbook1/audacity/ubuntu trusty main (audacity and audacity-data 2.1.2-1~14.04).

Every choice on the Effects menu is greyed-out. There is no choice for Add/Remove plug-ins either.

Further, under Preferences | Effects, the only thing I can do is check the checkboxes to enable LADSPA, Nyquist and VAMP effects. (They are all checked.) No other choices here.

Everything seems to work from the Generate menu, but the Analyze menu’s choices are also all greyed-out.

I’ve installed, uninstalled, reinstalled, switched between versions, uninstalled and switched back, deleted .audacity-data, and copied an old one from a backup. I’ve even downloaded the source and placed all the .ny files in .audacity-data/Plug-Ins. All to no avail.

Interestingly, right from the start it had all my chains, knew my toolbar layout preferences, and File | Recent Files… shows what I was working on before I decided to install a batch of larger hard-drives and re-install from scratch. Of course, these go away when I nuke .audacity-data.

What next?

Have you tried pressing the yellow Stop button and closing all other Audacity dialogues?

2.0.5 does not have Add / Remove Plug-ins and has no way to disable built-in effects. 2.1.2 has Add/Remove Plug-ins and can disable built-in and plugin effects individually.

Both 2.0.5 and 2.1.2 can disable plugin types such as Nyquist or LADSPA globally, as you noticed, but disabling a plugin type causes all effects of that type to disappear from the menus.

You could do with deciding what version of Audacity you want to use. Uninstall the version you don’t want to use. You should not have both 2.0.5 and the 2.1.2 PPA installed because it can cause problems.

Delete the ~/.audacity-data/ folder before running your chosen version of Audacity.

Then obtain the Audacity Manual for your chosen version. You can download the 2.1.2 or 2.0.5 Manual from Audacity download latest version.

If you want to install the Manual so that you can access it from the Help Menu in Audacity, unzip the “help” folder to /usr/share/audacity.


Gale

No other dialogues were open, but you hit on the answer nonetheless. I thought, “What’s he talking about? The stop button is brown unless you have a file open…” Oh. One needs to have a file open. < facepalm >

Near as I can figure, what had happened is that finding my chains were there, I jumped right in to apply chains to a batch of files. Of course, there are subtle differences between filter names and parameters between the two versions. At the first hiccup, I closed the file before investigating, since I don’t like to muck about with software when I have open files. From there on in, I did everything without opening a single file.

This morning, I uninstalled 2.0.5 using the “Mark for Complete Removal” option of Synaptic Package Manager, saved my chains elsewhere, zapped ~/.audacity-data, reactivated the PPA and installed 2.1.2. Then I opened a file, discovering the filters were there and selectable. I closed the file and went back, finding them all greyed-out.

One of the design intents of the package managers is specifically to prevent multiple installations, and multiple versions installed.

But you’re right, I need to choose a version and stick with it, if only to save having to edit chains every time I use one. At first I grumbled over the need, but have come to view it as an opportunity to clean out ones I no longer use and fine-tune the ones I do.

By the way, what’s up with ClipFix? It runs a order of magnitude faster. Not that I’m complaining. You may just have saved me from buying a new motherboard and processor.

Finally, I am getting an error when I’m exporting as FLAC at just after the stage where I edit the metadata. Dang. I’m used to vbulletin. Can’t insert a graphic here, eh? Okay. Typing it in…

An Assertion failed!

…/scr/common/wincmn.cpp(478): assert “GetEventHander()==
this” failed in ~wxWindowBase(): any pushed event handlers
must have been removed.

If I continue, things carry on merrily with no apparent issues.

Thanks for your help and patience.

I can’t believe I did all that back and forth without ever opening a file…

You will see that Phaser and Wahwah are active without audio present because they are real-time preview effects - you can open them when audio is already playing and twiddle the effect controls while playing audio to hear the result. However you can’t do anything with those effects with no audio present.

You can attach a PNG image file. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1

It was a known issue in 2.1.2. It is believed fixed in our current code, but it needs testing because it was never 100% reproducible in the first place.


Gale