New bug/feature with 3.4 noise reduction

I 'm a long time Audacity user and noticed a change in 3.4 that is creating some problems for me regarding noise reduction. After I get the noise profile, if I apply it to an entire track, the track shortens by about half and moves to the right. If I apply it to a smaller portion of the track it works normally. Under preferences / tracks behaviors I unselected “Editing a clip can move other tracks” but it didn’t solve the issue.

Any ideas?

Does this just happen in one specific project? If you close Audacity and then create a brand new project, does the problem still occur? (I’ve not been able to reproduce the problem here).

I just tested with a new project and the problem did not occur. The project I am working was created with the previous version of Audacity, so I tried Noise Reduction with another older project and the error did not occur there either, so it appears to something specific to this one project. I can manage that. Thanks for the quick response!

I’m having the same problem with multiple effects, and it’s driving me crazy. Let me list them out.

  • If I try apply a Limiter, it shortens the entire track, and shifts it to the right, which of course unsyncs it from the rest of my tracks

  • I tried using Low Pass Filter, and I can’t even describe what it’s doing, it doesn’t shift it, it just repeats a certain part of the track, almost like it looped.

  • Strangely, if I try to do something as simple as Splitting the track, not only does it not split, it actually ends up doing the Low Pass Filter effect that I had already undone.

I know this sounds unbelievable, and it’s something I’m missing, but I tried so many things. I was using the latest version of Audacity, and tried about 5 older versions to see if it was a bug.

Anyone have ideas on how to fix this? I’m pretty sure that my issue is very closely tied to the original problem described on this post, this issue of it shifting, even though we have the option unchecked for effects can move clips, even though the type of effects we’re applying doesn’t seem to have anything to do with that.


Do the problems that you are experiencing only happen with projects that were previously created in an older version of Audacity? If that’s the case then I agree that they are probably the same issue. If not, then most likely they are unrelated and should be posted as a separate issue.

1 Like

Hi Steve,

I created the project originally in 2.x (I can’t remember which), and then decided to upgrade to the latest version (I know better now to not upgrade mid-project).

As a test, I went back to my original project, an .aup file, created in 2.x, and went ahead and opened it in the version of Audacity I happen to be using now - 3.0.2. I had had the very latest version, it’s just that this is the version I’m incidentally on at this time, when I installed older versions during my troubleshooting.

So yes, I tried all my functions here (Soft Limiter, Split, Low Pass filter), and they all work as expected - in this older project (aup) vs the newer saved version (aup3).

For me, some clips have also been shifting left and right after applying effects in 3.4. I believe it was time stretching or pitch correction which behaved oddly for me.

In my case, it was a new project. I did use the new beats/bars grid, but I cannot replicate it all the time anymore.

I am also experiencing track shifting to right when using various effects with latest version of Audacity

This problem has been reported to the developers. Hopefully, it will be addressed in 3.4.2. Until such time, may I suggest reverting to 3.3.3: Old Audacity versions download

This topic was automatically closed after 30 days. New replies are no longer allowed.