Need just a bit of help compiling with LADSPA categories and


Pretty inexperience with compiling with options and variables. I think I got the options flag right, but I do not know what to type to define the variables. I found the following information, but I am not sure how to actually do the .configure command:

compile with USE_SLV2 defined and libslv2 enabled.
USE_LIBLRDF defined and liblrdf enabled
To assign environment variables (e.g., CC, CFLAGS…), specify them as VAR=VALUE.

I got this far:

./configure --enable-libslv2=yes --enable-liblrdf=yes

what do I add to this line (assuming it is right) to define USE_SLV2 and USE_LIBLRDF?

Thanks for any help on this…really looking forward to categories (yay!) and trying some of the LV2 plugs.

I am trying to compile for LADSPA category support and LV@ support. What I found was that I have to

compile with USE_SLV2 defined and libslv2 enabled.
USE_LIBLRDF defined and liblrdf enabled
To assign environment variables (e.g., CC, CFLAGS…), specify them as VAR=VALUE.

I am guessing that config should look almost like this:

./configure --enable-liblrdf=yes --enable-libslv2=yes

but I do not know what to type to compile with USE_SLV2 and USE_LIBLRDF defined as I am too much of a noob to know exactly what that means in terms of what to type.
I am compiling from audacity-fullsrc-1.3.13-beta.tar.bz2 on Ubuntu 11.04
Thank you for the help!
I tried posting this earlier, but it did not show up, so sorry if this is a double post.

I am not a Linux guru but on Windows I change these in the code, not on the command line for the compiler (I know it can be do there as well but have never done so). Search each #define:

Find all "USE_SLV2", Subfolders, Find Results 2, "Entire Solution", "*.c; *.cpp; *.h"
  D:audioAudacitySVNsrcAudacityApp.cpp(180):#  if defined(USE_SLV2)
  D:audioAudacitySVNwinconfigwin.h(30):// #define USE_SLV2 1
  D:audioAudacitySVNsrceffectsLoadEffects.cpp(70):#ifdef USE_SLV2
  D:audioAudacitySVNsrceffectsLoadEffects.cpp(290):#ifdef USE_SLV2
  D:audioAudacitySVNsrceffectsLoadEffects.cpp(318):#ifdef USE_SLV2
  Matching lines: 5    Matching files: 3    Total files searched: 1146

and make sure the value is set to 1 and not commented out:
// #define USE_SLV2 1
should be
#define USE_SLV2 1

Do the same for the other.

That did it, thanks. It compiled and ran fine, but when I open audacity, there are no categories and no lv2 plugins. When I open pref/effects, there is no entry for lv2, just ladspa, vamp, and nyquist. Any ideas what I did wrong or what I need to do next?

To enable effect categories you need to find the line:


in /src/Experimental.h
uncomment that line so that it reads:


I did this

I could not find any line with

#define USR_SLV2 1

in it so I added

#define USR_SLV2

to the file experimental.h (with no “1” which I am guessing is a windows thing, then ran

./configure --enable-liblrdf=yes --enable-libslv2=yes --with-midi=yes

Everything compiled fine, and audacity runs, but there is no categorization and no lv2 support that I can see. Any ideas what I am doing wrong?

I did not check midi support. SHould the “–with-midi” flag have an argument [yes] or just be left without one?

Any ideas what I might be doing wrong?

Since it appears to be defined in a Windows header:
winconfigwin.h(30):// #define USE_SLV2 1
I suspect you will need to define it on the command line when you compile. I don’t do much of this anymore and do not recall if it is done in configure or make. You might get away with adding the above #define in some high-level include file or in any source file where it is used.

I added it to experimental.h, but that did not work

Is there a linux equivalent to configwin.h? I coulod try defining it there instead.

I checked through the help file for configure with no luck. Also the install and readme files in the directories where the lv2 related files are. will look at the man page for make.

I think I am just missing something pretty simple here, because the categories did not compile either, although I found the def for that and uncommented it. Any other ideas?

As far as I know, you won’t be able to compile with LADSPA categories and LV2 support. The configure commands you would have used:

 --with-redland          use Redland for reading RDF data
 --with-slv2             use SLV2 for loading LV2 plugins
 --with-liblrdf          use liblrdf for categorisation of LADSPA plugin

were ripped out in 2009.

Defining EFFECT_CATEGORIES in src/Experimental.h should be sufficient for categorisation of built-in and Nyquist plug-ins, as I tried this only a few months ago. Have you done make clean, ./configure and make dep to be sure?


well that solves that with nothing lost but a few hours of wasted time :frowning: I was able to workaround by loading the lv2 plugins into lv2rack and using jack, which is what I should have done in the first place. Categories would still be useful though.

p.s., and sorry to sound ungrateful to those who took time to reply–thanks for replying!

That should still work for built-in and Nyquist plug-ins if you #define EFFECT_CATEGORIES in src/Experimental.h. If it doesn’t work, try a fresh checkout.


I checked that immediately before my previous post, so it was definitely working on 21st July and there have been no changes that I’m aware of since then that will affect that.