Need input, Stephanie!

I’m using Manjaro with kernel 5.6.10-3 and Audacity 2.3.3, installed via pamac.

Help → Diagnostics → Audio device info… has this to say about my motherboard’s onboard audio:

Device ID: 6
Device name: HD-Audio Generic: ALC892 Analog (hw:1,0)
Host name: ALSA
Recording channels: 2
Playback channels: 2
Low Recording Latency: 0.00580499
Low Playback Latency: 0.00580499
High Recording Latency: 0.0348299
High Playback Latency: 0.0348299
Supported Rates:
Device ID: 7
Device name: HD-Audio Generic: ALC892 Alt Analog (hw:1,2)
Host name: ALSA
Recording channels: 2
Playback channels: 0
Low Recording Latency: 0.00580499
Low Playback Latency: -1
High Recording Latency: 0.0348299
High Playback Latency: -1
Supported Rates:
Device ID: 9
Device name: pulse
Host name: ALSA
Recording channels: 32
Playback channels: 32
Low Recording Latency: 0.00868481
Low Playback Latency: 0.00868481
High Recording Latency: 0.0348073
High Playback Latency: 0.0348073
Supported Rates:

It’s an ASRock B450M/ac, if that makes any difference.

Setting the Recording Device to Generic: ALC892 or ALC892 Alt results in the Error Code -9997 Invalid Sample Rate problem, possibly because there are no listed sample rates? It doesn’t matter if I change it to any of the options in the drop down for various sample rates, any road. Setting it to pulse gives no input volume, despite being able to see the little volume bar in pulse audio mixer bouncing and hear the microphone through my headphones if I open the device as a stream in VLC, and a couple of simple audio recorders (one by something like that for a name, the other I forget aside from being a female name) installed from pamac also work fine right off the bat.

Basically, only Audacity is being obstinate. Anyone know how to correct its attitude?

Audio device info allows you to save the info as a text file. Please do that, then attach the file to your reply so that I can see the full info.

Righto, here it is then.
audacitydeviceinfo.txt (4 KB)

Indirectly yes. The device is probably being used by PulseAudio.
You can check that in PulseAudio Volume Control (pavucontrol). Click on the “Configuration” tab and see what is selected. It will probably say something like: “Analog Stereo Duplex”.

Yes, that’s what I called pulse audio mixer before, as it’s what opens when I select “Audio mixer…” from the menu on my system tray sound icon. It’s actually called “Starship/Matisse HD Audio Controller Analog Stereo,” and it’s the only option aside form the monitor stream for my computer’s output through the HDMI port. The little bar graph dances happily according to what the microphone picks up, VLC and other audio recording software hear it just fine, Audacity gets nothing.

Same here on Xubuntu.

An important feature of PulseAudio is that when it uses an audio device, it takes exclusive control of that device. Other applications are not able to use that device while it is being used by PulseAudio.

If you ensure that no other audio applications are running (including your web browser and including the PulseAudio mixer), and then launch Audacity, you should be able to use Audacity with the ALC892 analog device.

Alternatively you “should” be able to use Audacity with the “Pulse” device (uses PulseAudio).
When using Pulse for recording, you will need to use the PulseAudio mixer to adjust Audacity’s recording level. While recording (or “paused recording”), Audacity should appear in the Recording tab of the PulseAudio mixer.

AHA! That was the problem. I hadn’t checked the “Recording devices” tab while actually trying to record, so Audacity wasn’t shown there, and when I paused recording and did it just now it had the HDMI monitor set as the input device. And here I thought I’d tried all the reasonable and obvious things before posting. I know it must be tiresome answering the same or almost the same noob questions all the time, but having a friendly new user experience in the forum can make all the difference for adopting a new piece of software and giving up on it, so thank you for the help, not just from me but for all the noobs past and future, and everyone who’ll hear something they made after getting set to rights. You’re awesome, and you should feel awesome.