Need Help With USB Audio Connection

Ubuntu 14.04.5 LTS audacity 2.0.5 pulseaudio 4.0 Alsa driver k3.13.0-100-generic

I’m trying to record LP records using an external audio interface ( ARTS USB Phono Plus) appears to my machine as a USB Audio device.
0 [CA0106 ]: CA0106 - CA0106
Audigy SE [SB0570] at 0xbf00 irq 21
1 [U0x46d0x809 ]: USB-Audio - USB Device 0x46d:0x809
USB Device 0x46d:0x809 at usb-0000:00:13.2-5, high speed
2 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfcffc000 irq 19
3 [CODEC ]: USB-Audio - USB Audio CODEC
Burr-Brown from TI USB Audio CODEC at usb-0000:00:12.0-2, full speed

The USB audio is recognized by alsa (i.e. alsamixer) and by pulseaudio (volume control) widget
but not by audacity.

When I run audacity and try to select an input source, the only choices I’m given are

  • the CA0106 sound card
  • pulseaudio inputs
  • “default” inputs

None of these are the USB Audio CODEC.

I assume this is a configuration problem on my system, but I’ve run out of things to try.

Where does audacity get the list of input sources that it presents as options for input selection?

Audacity searches for available audio devices during its start up. It does not look again unless you specifically tell it to: “Transport menu > Rescan audio devices”.

Normally you would connect the USB device first, wait a few moments for the device to be recognised and connected, and then launch Audacity.
To check to see what devices Audacity has found, open “Help menu > Audio device info”.

I’ve already tried

  • connecting the USB device and then rebooting to a clean system
  • using transport → rescan audio devices

Neither one solves my problem. Audacity still does not see the USB audio device.

What is the other USB audio device apart from the ARTS?

Please save Help > Audio Device Info… (top right of Audacity) as a text file and attach it. Please see here for how to attach files:

If you install pavucontrol (Pulse Audio Volume Control) and make the ARTS the selected device in that, then the pulse or default recording devices in Audacity “should” be the ARTS. But the ARTS should show up as a separate (hw) device too for accessing it directly without pulse.


deviceinfo.txt (6.9 KB)
Hey Gale,

I’m having the same issue. Here’s my Audio Device Info. The issue is that the “CORSAIR HS70” device is headphones with an optional mic attachment. For some reason, it is showing as having a recording channel, but no playback channels, despite working everywhere else on my system.