Need help saving WAV in correct format.

Hi, my 1st post here, so please forgive me if this seems an obvious question.

I have a piece of music hardware which can import WAV files.
My device manual states: “WAV formats supported to 16- or 24-bit samples, recorded at sample rates from 44.1 to 96 kHz”

However, when I use Audacity to export a short sample and I think I’ve set things according to these rules, my music device always says “unsupported format”

I have found a fix, in that I can then load this exported file into AVS Audio Converter and back out again as what seems to me the same format?
And then it works and is accepted by my music device.

So I guess I’m doing something wrong?
I know it’s probably hard to know but might anyone have any ideas?


Everything looks OK.

Check the Project Rate in the lower-left of the Audacity Window. (That’s the sample rate of the new file you’ll be creating and it can be different from the files you imported/opened.)

You can also compare the “good” and “bad” WAV files with [u]MediaInfoOnline[/u], and of course if they are the same they should have the same file size.

Thank you for the suggestion.
This will give me a bit to experiment with and post my findings

Done a little testing and so far it appears the Sample Rate if the main difference between something straight out from Audacity and the same file once converted.

Audacity appears to want to export my test file with a 32khz sample rate.

I’ll admit I’m a little puzzled as to why.
I’ve selected the little drop down box in the sample area and changed RATE to 44.1
I’ve also used the TRACKS / RESAMPLE option to change it to 44.1 also.

But upon saving & checking the file it’s still 32khz

I don’t feel like it’s actually resampling, as after I used the RESAMPLE option, I go back to this option and it’s on 32000 again.

Am I doing something wrong here?

The project rate (bottom left corner) is the export sample-rate …

Thanks for that.
It seems that was the problem, despite the info to the left of the sample saying one thing, it was the box at the bottom, which you highlighted, which actually was what the file was being saved as.
Working now :slight_smile: