Need help recording Windows Sound

I’ve read quite a few forum threads regarding my similar issue. I’ve read the manual regarding recording with stereo mix with Windows 7 64bit. I have stereo mix enabled and selected as default and inside audacity it is selected as the input device. I have check the recording volume at it looks to be turned all the way up. I can’t find anywhere that it is muted, but when i try and record say a youtube video and get the sound, nothing is recorded and nothing is showing up in the mix lvls. I’m sure i’m being a complete noob and over looking something, so if anyone could point me in a direction i’d really appreciate it!


You have posted in the Audacity 1.3.x section.
Audacity 1.3.x is an old discontinued version - you should upgrade to the current version as soon as possible.
I would suggest that you uninstall Audacity 1.3 first, then install 2.0.2 which you can get here:

Onto the problem:
What settings do you have in “Edit > Preferences > Devices”?

Dog gone it. I meant to post this in the Audacity 2.0+ thread. I’m using the latest Audacity version. Could an admin move this thread to the correct location possibly?

To answer your question, this is how it is set up under devices:

Host: Windows DirectSound

Playback: Primary Sound Driver

Recording: Device: Stereo Mix (Realtek High Definition Audio)
Channels: 2(stereo)

Really appreciate the help!

Moderator note: moved this thread as requested.

If Audacity is recording what appears to be a flat line, try using the Amplify effect (default settings).
If that enables you to hear what you have recorded (albeit that there will probably be a lot of noise and bad sound quality) then you need to adjust the levels in Windows. The recording level from stereo Mix may be affected by both playback and recording levels in Windows (it is helpful to have speakers with their own volume control).