Need help recording to existing mp3's


I have some backing drum & bass tracks (mp3’s) that I use for live band performing. We don’t have a bass player or drummer and these backing tracks work great. The backing tracks are on my ipod and we basically play along to them live. I have a Roland Fantom X-7 Workstation/Keyboard that I should be able to record sound effects, horns, etc. to the backing tracks on audacity which will further enhance our sound, but I’m having trouble doing so. Any help would be greatly appreciated.

Thank you,


Can you be more specific about what you are having trouble with.

If you can link your iPod to your PC for audio input, and do the same with your keyboard, then you should be able to use the multi-track techniques as done in this example:
This is geared towards vocals and condenser mic’s but the principles are the same…

I plug my keyboard into my computer via usb port, import a mp3 that I want to record to, click on “New Audio Track”, press “record”, and I don’t get any signal from my keyboard to the new recording track. The recording meters don’t seem to be picking up any signal at all. I have tried and tried to work this out but to no avail. Thanks, vert

Check the keyboard manual. I suspect that the keyboard does not send audio through the USB cable. The USB cable is most probably for midi data and not audio. If so, you will need to plug an audio output from the keyboard into a “Line level input” on your sound card (not a microphone input because microphone inputs are about 1000 x too sensitive).

If your sound card does not have a line level input, there are good quality USB sound cards with line level inputs available at very reasonable prices. (The Behringer UCA 202 and the Erirol UA-1EX are inexpensive and often get recommendations on this forum).

Thank you, and you are exactly right about that. I now have a Lexicon Alpha interface and it works. But now I have a different problem - When I click to record I am able to record what I want and it plays it back beautifully, but as soon as I click the record button all I get is very loud static, possibly white noise?, and I can barely hear my keyboard or the existing track that I am recording to. How do I get rid of this awful noise? Thanks Steve, Vert

Sorry I don’t understand what you mean - could you have another go at explaining (more words may be needed).

Forget what I said before, I downloaded the Beta version of Audacity and it seemed to want to work at first, but now when I click “record” it won’t record… a latency window comes up and says that the latency is causing the problem. I don’t know how to fix it. I’m so lame…could you please call me? 2085782260 I need help vert

Search for the file “audacity.cfg” and delete it (on Windows it is a hidden file, so you need to include hidden files in the search).
Then restart Audacity. It will now be back to how it was when you first installed it (and you say that when you first installed it you could record, so cross your fingers and all being well that will fix it.

I don’t think that you really want to accept reverse charges on an international phone call.

I deleted that file and nothing changed. What I am getting when I click to record is a window that says:

Latency Problem

Latency correction setting has caused the recorded audio to be hidden before zero.
Audacity has brought it back to start at zero.
You may have to use the Time Shift Tool or F5 to drag the track to the right place.

I have the latency setting on factory setting: 100 / -130

Sorry to bother you with this, Thank you very much vert

"Latency Problem

Latency correction setting has caused the recorded audio to be hidden before zero.
Audacity has brought it back to start at zero.
You may have to use the Time Shift Tool or F5 to drag the track to the right place

Is that the exact error message?
It pops up immediately when you press record?

After you deleted the audacity.cfg file and restarted Audacity, you should have been prompted to select your language - did that not happen?

I think I misread this the first time - you are not saying that it did work at some point, in fact it has never worked, but at one point is appeared to show a psychological willingness. Is that what you are saying?

That is exact message that pops up after I click the “stop” button after clicking “record” (because once I click “record” nothing happens and I have to click stop to start over)
Also, I don’t remember exactly if the record worked in the beginning…I feel that I am soooooo close. Thanks Steve, vert

I had the same error when i tried to record a second track while listening to the first one I recorded. I found that changing the Latency in the Edit>Preferences>Recording menu solved the problem. The values I am providing are arbitrary in that they worked for me…Audio to buffer: 300 and latency correction: -150. You may have to play around with these.
Hope this helps

I have this same problem with my lexicon alpha. I contacted Lexicon with this issue and they claim it is a bug with audacity’s stereo feature and suggested I select mono. This did not work. I do know this is a problem alpha has with other software as well but configuration changes correct the problem. Usually the fixes involve buffer adjustments and selecting 32 bit float (3 byte pcm) (programs like adobe audition). I do not know what the equivalent adjustments are for audacity, for instance 3 byte pcm versus 4 byte pcm. I agree changing latency settings seems to have some influence but I cannot solve it with that. I can say the problem is intensified with the quantity of tracks to be overdubbed. I understand that two way usb communications could be the culprit but other audio editing software can deal with this. Has anyone with a lexicon alpha successfully used overdubbing with audacity? If so could you divulge the configuration settings which work for you?