need advice re96/32float recording

Hello- a very long time user of cooleditpro/Audition 3x normally record at 96 using 32float. Thought I’d give Audacity a ‘new’ try (tried it in Linux in pre 0.x versions unsatisfied)
So installed newest stable 2x version yesterday on win7pro 64bit machine. That went fine. Set up preferences for recording at preferred sample/bit-s and fired up the program. Brought in my band for rehearsal and began recording- it ‘looked’ find (hate to even say this about audio) but playback was all choppy (not distorted by volume) distorted jittery etc- opened the wav in Audition 3 same problem. So is this a set up issue, a software issue-???just need some pointers.

Audition 3 is old and current versions are more and more attached to video production it’s also crash/computationally intensive so if I can get Audacity to work I’ll be able to uninstall A-3…

Thanks in Advance

Did you try it with default settings before you tried with your custom settings?
If not, try resetting preferences (reinstall and select “Reset Preferences” during the installation), then try recording with default settings.

What hardware are you using?
Which exact version of Audacity (look in “Help > About Audacity”)

there’s no point (unless you can explain the point) in trying the default settings as I would never use those.
As for exact version 2.1.1, soundcard Juli@ the rest of the set up is outside, two presonus preamps (tube) a FP10 interface all going into a soundcraft Spirit M8 stereo outs into Juli@

The .wav opened in both Audition 3 and Audacity 2.1.1 with the same sound issues.
Basically I can see that the signal from the mixer. I immediately recorded same set up into Audition 3 to make sure there was no problem and it recorded it fine.

So some hint’s please? If the only way to troubleshoot is to use the defaults this is sort of a dead end.


You might try increasing the buffer size (Edit → Preferences → Latency).

It’s probably a driver issue. Are you using the same drivers in Audition?

there’s no point (unless you can explain the point) in trying the default settings

There’s also no point in recording to 32-bit floating-point since you don’t have a 32-bit floating-point ADC. :wink: Your drivers are simply converting the audio data stream to 32-bit float before the data is saved.

Like most audio editors, Audacity works internally at 32-bit floating-point and there are good reasons for that.

Trouble shooting.
We know that “something” is wrong, but we have no idea what is wrong, so we need to narrow that down.
You may have changed a setting that is now causing the problem. We could all stab in the dark, throwing ideas of what the problem may be (tweaking the buffer size is a reasonable guess, but the default buffer size normally works well on Windows), but if we start from default settings then we all know where we are starting from.

Do you have a better idea of how to approach resolving your problem?

You are not recording at 32 bit. There is no audio hardware that has >24 bit output. There’s also no reason to.

The DAW will convert internally to 32 bit. They all do. That’s because the higher precision (and floating point) is far better for calculations and that’s what the DAW does.

I suspect more people have wrong settings because of the fact that this internal 32 bit is shown in the interface. It’s beginning to be my personal pet peeve with Audacity. It’s simply confusing. And it’s only “better” for those that do not understand, but believe that higher numbers mean better audio.

Also, what’s the reasoning behind using 96 KHz for a rehearsal recording?

For example if you did not get the “choppy” recording at default 44100 Hz Audacity project rate, it suggests that other devices (or Windows) have 44100 Hz settings and you are removing the mismatch, and/or that you don’t have the computer resources to record without dropouts or glitches at 96000 Hz.


Doug means the Edit > Preferences: “Recording” section then the “Audio to buffer” setting.


I’m back and now have read all your responses and thank you for taking the time.
I’m not going to respond to the snarky comments or get into the bit rate flames but I do now understand why to try a reinstall and just run it.

At first the suggestion about buffer didn’t make sense until Gale explained that the buffer rate is dependent on software not on my settings globally.

I will do this today and get back to you with the results.


I don’t think there was any intention for the comments re. sample rate and sample format to be “snarky”. Rather there is a lot of mis-information (mostly derived from sales hype) that encourages people to use much higher sample rates and formats than is actually required. I would venture to say that “most” professional studios usually record at either 44.1/24 or 48/24 (depending on whether they are working audio only or audio+video).

Anyway, good luck with the tests. Let us know how it goes.

Just for general background information, here is quite a good (and not too technical) article that puts the case for and against high sample rates:

The case for sample format is much more clear. High resolution formats such as 32-bit float are best for processing audio as it avoids rounding errors. The format that is actually captured is limited by the audio device and sound system. The highest bit-depth that sound cards can capture (to date) is 22 bits, (with two lsb padding or noise). When “recording at 32-bit”, the data is padded from the actual number of bits delivered by the sound system (usually 16 or 24 bit) to 32-bit. Note that Audacity uses “32-bit float” rather than “32-bit integer”.

Ok I uninstalled and reinstalled and hit record and discovered I did have to go into preferences to set my soundcard up correctly (or audacity to use it properly)
Hit record got a recording with the same problem in default settings. I tried changing the buffer settings in various ways and all the changes made it worse.
So hints about buffer settings may be in order. Or more ideas.
BTW I remember in the really old days at the start of linux versions of Audacity that getting it to work was difficult. I’m sorry that I’m having such trouble with it.

So was this 44100 Hz, 32-bit float?

And MME host in Device Toolbar?

And did you enable the “Reset Preferences” box when you reinstalled Audacity? That is always a very good idea.

Could you attach an audio sample of the jittery recording so we can see and hear it? See


So Gale no, I didn’t think a reinstall would have the settings I had given a previous install, but now I will go an wipe out Audacity and start over. I do not know where this default reset is (just briefly looked didn’t see it.) and the MME thing what???
I see MME in a box and so I guess the answer to that is yes.
So let me try one more time to get to the defaults of 44/32 or 16 or whatever IF I can find that reset thing and I’ll make another recording because I see that the reinstall did not return the product to it’s defaults.
Thanks for whatever patience you have been using.

I wiped all traces of Audacity from the computer came back to the site downloaded 2.0.2 and other than changing recording to line input did nothing else so the recording WHICH WAS FINE was at 44/16

NOw the question(s) remain how to get the high sample rate to work, and if I need to change the buffer please make a suggestion(s).
Also I didn’t try to do anything else such as bit depth change and if that should be tried first let me know.


You would be much better to use 2.1.1 which has the latest bug fixes:

Please don’t use abbreviations :wink: . Please write things out long hand so we know what the settings are and where you make them.

Is the project rate bottom left 44100 Hz?

Where is the “16”? Do you mean you exported as 16-bit WAV?

There is no guarantee it will “work”. We don’t even know what the exact problem is - we have not heard a sample of it.

If your Juli sound card can adjust buffer settings, yes it may be those settings are set very low in the expectation that you have a recording application that uses ASIO. Unfortunately Audacity as shipped does not support ASIO.

We don’t know the exact model number of this Juli card, so we can’t tell you if it can change buffer settings. Does it have a control panel you can look in?

The problem may be nothing to do with buffer - it could be mismatched sample rates. If you are using MME host in Audacity and want to use 96000 Hz project rate in Audacity then I strongly suggest you set Juli to 96000 Hz (if it has such settings in a control panel ) and set Windows Default Format for Juli to 96000 Hz.

To set Juli Default Format to 96000 Hz, right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the Juli then choose “Properties”. Then click the “Advanced” tab and adjust Default Format. OK and OK and restart Audacity.

If that does not work then you can try the other hosts in Device Toolbar (Windows DirectSound or Windows WASAPI). If you choose either of those hosts, I suggest you enable both “Exclusive Mode” boxes in Windows (underneath the Default Format section). Then the Default Format will be ignored providing you choose DirectSound or WASAPI.

Have a read of these links: .


I will try to remember to write out all the zeros from now on.
There has never been a problem with recording 96000 at 32float in Audition 3.1 with my soundcard. None with buffering etc. So setting that should not be necessary as it already works. As far as I know there aren’t versions of Juli@ and looking it up that seems to be so. I haven’t run into problems using Auditions 32 float setting the card will go 192000 24bit.

As for downloading 2.1x all I did was go to the website and 2.0.2 was what was offered at that moment. I don’t know what that is about, just reporting.

As for setting sample rates that has never been done and I don’t think it can be done in the card (I’ve had this card through 3 different machines, with various sample rates and recording and playback has always just worked again with ancient cooleditpro through to Audition 3.0 and I have tried Ableton and older programs even Protools lite and never had to tweak the soundcard).

For where we/I am now…I believe I have done what you asked (to the point I could) I downloaded the program started over and made a recording without changing anything except input. However the program comes is what produced a recording with no problems.

What I was asking and ask again is “what should I try next since the sample rate in default worked?” My goal is to get to a place where I am recording at 96000 and 24 or 32float bit depth.


Just writing “kHz” would be fine :wink:
The important thing is clarity - you’d be surprised at the amount of confusion that crops up on the forum due to “insignificant details” (such as the difference between “kbps” and “kHz”). Clarity is good, and it helps people that read this in the future.

So to recap the current position:
Your ESI Juli@ sound card works fine with Audacity 2.1.1 with the default 44.1 kHz sample rate, 32-bit float (default) settings in Audacity, but the recording is choppy if you change the default sample rate to 96kHz? Is that correct?

If that is the case, the next thing that I would try is, with “Quality” set to 96000 Hz 32-bit float, try increasing the “Audio to buffer” (in "Edit > Preferences > Recording) to say “200” and see if that makes any improvement (or makes it worse).

This is ‘nuts’ (translation don’t understand)
1] because I wrote that I had just gone to the website to download what was offered (v2.0.2) and then you asked to confirm 2.1.1 so I went back and downloaded that to be able correctly answer your question. I still don’t know why the first time 2.1x wasn’t offered but so be it.

2] I, incorrectly, assumed that since 44.1Khz worked fine in v2.0.2 that it would work in 2.1.1 so I didn’t try that at first, but I couldn’t and still can’t get Audacity to record any signal at all in version 2.1.1. I changed the settings back to 44.1Khz tried MME and the other two options, changed line to stereo mix to mic inputs in the 'box and no signal showed. I tested with Audition and the signal is coming into the computer.

So I’m stuck again.
And I have a student who just arrived so have to sign off.

UPdate- I have a sample for you v2.1.1 MME 44100 32bit had to change the input in the software a couple more times and finally got signal but as you will hear yikes?!