Mysterious digital corruption during recording

Hi -

I used audacity 1.x with my old 10.4 mac and motu ultralite interface for 10 years no problem. now i use 2.1.2 with my new

MacBook Pro (Retina, 13-inch, Early 2015)
2.7 GHz Intel Core i5
8 GB 1867 MHz DDR3 RAM
running MacOs 10.11.3.

i largely use audacity to digitize my vinyl record collection. i recently discovered that many of my files have been corrupted by a strange digital sounding distortion. the files LOOK normal, and i when i listen while recording (software playthrough off - i am monitoring my interface’s sound) i do not hear the distortion. i only find out about the distortion when i listen back to the unbounced WAV in the audacity window, or sometime later when i listen back to exported flacs (as i did today, to discover that over ten hours worth of sides have this corruption).

my motu interface is old - yes - it is firewire 400. i run a firewire400-800 cable i bought on the internet into an apple official firewire800-thunderbolt adapter. but i called motu recently and was told that the most recent motu driver should support my interface.

my interface displays recording at 44100 Hz, as do my audacity settings.

i should add i had other weird issues with audacity crashing and my interface turning itself off, but that was mostly solved by running the motu off an external powersource (plugging in AC adapter). im frustrated because i never had any issues whatsoever running the old software on an ancient system and now that im in the 21st century, its just been problem after problem.

i have managed to avoid the problem so far today - i have recorded 3 sides WIFI off, latency settings to 0 and hardware and software playthrough off and i’m now running audacity 2.1.1.

attached is an example of the corruption where it occurs - 22 minutes into the recording. this is not something that is consistent - sometimes its 3 minutes in, sometimes its 20 minutes in, they generally start out okay unless a previous recording was corrupted also.

anyone else encountered this? discovered any workarounds??

i recently discovered that many of my files have been corrupted by a strange digital sounding distortion.

Which files? The ones you’ve been doing on the new machine or the older machine?

I’ve been known to listen to the Mac rather than the interface to guard against surprises like this. Yes, it’s “one computer late” with an echo, but unless you’re trying to do real-time critical-time production, it doesn’t matter, and it does let you hear what Audacity is doing.

Audacity > Preferences > Recording > [X] Playthrough… (select).
Turn Overdub off.

It’s a little concerning you managed to find and install Audacity 2.1.1 because the current supported version is Audacity 2.1.2.

There are a number of bogus versions running around with no pedigree.

If you want to trash the old Audacity (probably a good idea) you’ll need to trash the preferences separately.

Go (top of the desktop) > Go To Folder > ~/Library/Application Support
Take the “audacity” folder to the trash.

That really does take Audacity back to First Birthday, so you should make copies of any plugins or add-ons supplied buy you.

Oh, and yes. I did get a machine to do a similar error, but it only happened once and we could never make it happen again. If you can’t break it on cue, fixing it is stunningly difficult.


thanks, yes the issue occurs on the new machine, my old one is fried.

well unfortunately i cannot make it happen with any reliability but 33 out of about 200 files i’ve recorded in the past two months have this corruption, so it is happening with me on an unnervingly regular basis.

going forward i will use software playthrough to monitor for this issue and see if i can discern any unifying factors …

Can you make it worse? I know it may seem counterproductive, but if you can change the problem in any way, it may give us a clue how to cure it.


2.1.1 or 2.1.2 probably won’t make any difference. The other moves are good (only setting “Audio to buffer” to 0 makes a difference, not “Latency correction”).

Also, mitigate power saving features in Mavericks or later that can interfere with recordings.

  • Right-click or CONTROL-click then “Get Info” and enable the “Prevent App Nap” checkbox. This should prevent the Mac putting Audacity into a paused state when it does not have focus.
  • A few users have reported that Antipop helps. This prevents the Mac shutting down the audio system when there is no playback.


I"m guessing your are using the original Motu UltraLite, not the MKII, or the MKIII?

In that case, the Firewire cable could be too long or too old. The UltaLite is a rock solid interface, but it has become of age and it’s starting to show problems like yours. The error correction on the Firewire port isn’t able to cope anymore and it’ll drop out or distort occasionally.

Using a shorter, good quality cable should solve this and is easy enough to try. Also, check if the FW connector in the Motu hasn’t come loose. If you can wiggle the connector a bit, this could be the cause too.

As a first test, you could try another recording app, to rule out Audicity, but I’ve never known Audacity to do this.

As a side note: FW interfaces on a Thunderbolt adapter should ALWAYS be run with external power. I’m amazed that your Motu even works at all on Thunderbolt bus power!

thanks everyone …

yup! OG, probably 2007. firewire 400 only …

the ports are pretty loosy goosy

and i have quite a long firewire cable - it’s new though, but cheap. its fw400-fw800 … then im running it through the apple fw800-tb converter.

i had suspicions it might have been hardware, but i had such a good run with the MOTU.

woulda checked on their forums but i saw a lot of months old posts that had gone unanswered.

i’ll get a newer, more expensive cable and cross my fingers i guess, for now.

Just listened to the sample and sounds like same issue I’ve had on my Mac Mini. I think this is related to Apple CoreAudio and not Audacity. You may want to try some of the tweaks listed in this link:

I get this error using Logic Pro X at times, (also the Disk too slow error) and following some of the above tips helped a bit. I still have some issues with it and I’m on El Capitan. I did see that they are saying to set default for your interface to 48000 for OSX 10.9 and up and buffer to 512. I’m using a Scarlett 18i8 USB interface and have had some results come out exactly like your sample, so I don’t think it’s the firewire cable you’re using. One thing that has helped for sure is turning off Spotlight indexing, disabling AppNap and adjusting the power settings. Most say set Computer sleep and Display sleep to Never and untick the checkbox “Put the hard disk(s) to sleep when possible”. Others say to turn off WiFi and Bluetooth if possible, but hasn’t helped me as I have bluetooth keyboard and mouse so unable to try that option.

good luck and post back if something helps or works.

Just noticed you said you’re running 10.11.3? Have you tried getting the updates? I think El Capitan is currently on 10.11.5.

just a quick note - something very strange happened last night.

i have not yet upgraded my OS, and i haven’t bought a new cable. so that’s still a possibility.

i have changed my settings to 512 latency and 48000 hz in audacity and on the interface.

seems to actually happen even more frequently now … almost every other time i record a side off an lp. i have gotten pretty fast at lopping off corrupted segments and splicing on a non-corrupted recording.

okay here’s where it gets interesting, because i previously did not think this was possible.

i’m listening along to a beethoven string quartet when about 28 minutes through i get my oh so familiar mysterious corruption. this time i decide to let it run to the end so it’s a little easier to match the wav files when i go about re-recording the last five minutes of the side (to replace the corrupted segment).

now … being that my file is already busted i decide to flip on the wifi and - voila! - the mysterious corruption disappears, mid-recording, the second i re-enabled the wifi. my file sounded perfectly normal again. of course i still had a few minutes in the middle of the take sounded like muddled garbage, so i had to re-record and splice again anyways, but i certainly thought this even more mysterious de-corruption was worth note!


I have never known switching off Wifi to fix anything. So I wouldn’t expect switching it ON would fix anything either.

Some networking stuff has changed considerably in El Capitan. And Firewire is a networking port too.

I have to meditate on this one. :open_mouth:

You’ll find several reports on this Forum suggesting that turning off WiFI on Mac’s can stop “clicky” playback and recording.


hi all –

sorry to revive this old thread but … i STILL have this problem. anyone know anything yet?

i moved and went for a long time without a really usable turntable, so i haven’t done much ripping until a few days ago when i bought a new sony turntable.

totally forgot about this weird issue until i listened back to a few of the sides that i ripped during the first couple days of ownership.

i’m still running audacity 2.1.2 and El Capitan (10.11.3).

it seems pretty clear this is a MACOS issue … has anyone found a stable release? i found some 10-year old forums where people were talking about this problem and apple recommended they downgrade to OS 10.4 (!!). this is the OS i was using on my really old macbook pro that never had this issue in its long life.

is 10.4 legit the last OS release that had a usable audio driver??

basically im wondering has anyone had this issue and had it solved by upgrading the OS? or does anyone have issues of any kind with the newest OS (10.13)?


This solution, using the current 2.2.2 version of Audacity, has worked for many Audacity users on Mac OS: