My new headset not recording System Audio Help.

I use Audacity and I would use WASAPI and did not need Stereo Mix enabled with my old headset. Now with my new headset I have to use Stereo Mix, WASAPI won’t work anymore, pretty weird issue to say the least. I installed Asus Realtek Driver I record in Mono. My mic boost is at +0.0db. I plugged in green jack in headphone port to record system audio and it does not work. I had no issue with my old headset recording system audio. Now I have an issue with this new headset. Any help woukd be appreciated. Here is the new headset I bought from Amazon. If you want to buy this headset for yourselves I highly recommend them, they sound great and mic picks up sound really well. [2015 New Version] eTopxizu ET2000 3.5mm Plug Wired Gaming Headphone with Noise Canceling & Microphone for PC Games Black Blue: Computers & Accessories

Weird issue is I get an error message in Audacity “Error while opening sound device. Please check the input device settings and the project sample rate.” whenever I use WASAPI on any computer with this headset. I set the playback device as headphones and recording device as headphones because my headset green jack is plugged in headphone port and red jack plugged in mic port. Another weird issue is the Asus Realtek audio drivers does not detect headphones when I plug headset or headphones in front headphone port on my computer. I do not see a headphones icon in playback devices nor in volume mixer when I plug in headphones. It only detects it as speakers, I still get sound from headphones but for some weird reason windows detects it as speakers :frowning:

Is that the correct audio driver for the machine? Is it an Asus branded computer?

As it says on, some devices won’t record WASAPI loopback in mono. Does the error go away if you change Device Toolbar to “2 (Stereo) Recording Channels”?

You can convert a stereo recording to mono using Tracks > Stereo Track to Mono.

See my question above about drivers.

Usually Realtek has a control panel in the Windows Control Panel. You should have a look there. Sometimes there are settings for tying up internal and external inputs or outputs into one visible port.


Here are my computer specs.

Case: Corsair Graphite Series 380T

CPU: i7 4790k 4.00GHz Quad Core

Motherboard: Asus H97I-Plus

Ram: 8GB

Hard Drives: 500GB HDD and 120 GB SSD Kingston

Power Supply: Corsair RM650 Watt (Modular)

Video Card: MSI R9 270 Twin Frozr 2GB

OS: Windows 7 64Bit

Water Cooler: Corsair H60 CPU water cooler

Monitor: Acer H257HU

Thanks for the details.

Well, on the available Realtek audio drivers are lower than yours, “Version” and “Version” (both drivers are for Windows 7 64-bit with the same release date).

So assuming you obtained your drivers from that site, it’s up to you whether to go back to either of the above versions or not. You do want to get the drivers from that Asus site. If you obtained the drivers anywhere else, you likely won’t have the proper drivers matched to that exact motherboard.

Did you record without error with WASAPI loopback in stereo?


I already tried older driver versions and still the same problem :frowning:

Regardless, only use drivers from that ASUS site. Random drivers from other sites are usually a bad idea.

What exactly Is the problem?

Can you record without error with WASAPI loopback by changing to stereo recording in Device Toolbar?

Why do you want mono recording? As I said, if you want a mono track but have to record in stereo, use Tracks > Stereo Track to Mono.

If you tell us what exactly you are trying to do, we may be able to help you.

WASAPI is less compatible than the other hosts you can choose in Audacity, so you may receive errors. If you made changes in Windows Sound, you must restart Audacity or you may receive errors.