My Audacity 2.1.2 no longer works [SOLVED]

I have used Audacity 2.1.2 successfully when I was using Windows 7. I recently upgraded to Windows 10 and now Audacity 2.1.2 no longer shows a waveform while recording a song playing through my sound card. There is no sound when I try to play back the recorded project. I tried uninstalling Audacity and Lame. Reinstalled and have the same result. What can be wrong.

song playing through my sound card

Windows 10 may not like your soundcard. Devices under Win10 have to be rated for Win10. Check for updated drivers or Windows 10 support software. It has to say Windows 10. Just “OK for Windows” won’t do it.

If you get blue waves on the timeline when you record, then you are getting a recording whether or not you can hear it. Recording and Playing are two different things.

Audacity may not be sending sound to your speakers or headphones so you can hear it. Set that with the Device Toolbar.

If you have a flat line instead of blue waves, then you are not making a recording.


  1. I presume windows 10 and my sound card are compatible because every other sound, either computer generated, you tube, or Spotify all play fine through my speakers or my headset.
  2. While audacity is running all I see is a pair of flat lines during the recording and playback with no sound on playback. I did presume that audacity was not actually recording the song. That begs the question as to why it no longer records.

Every other software program I have apparently did not have a problem working under windows 10. So any ideas as to what audacity is missing. Is there a windows 10 driver that IT needs? Is there something I can check?

As Koz said, you have to choose the correct recording device in Audacity’s Device Toolbar. For recording computer playback, that probably means choose Windows WASAPI host and the (loopback) recording device for the same device you are playing the sound on. See this link:

Recording is more demanding than just playing sound. If you upgraded to Windows 10 over Windows 7 on the same computer, sound and especially recording may not work correctly unless you update the drivers of the audio device to Windows 10. This means going to the web site of the computer manufacturer and looking for Windows 10 audio drivers for your specific computer model. Read this link carefully:


Thanks for the advice. Since audacity just automatically worked when I installed on windows 7, I rashly assumed that it would be the same with windows 10. Changing the MME to Windows WASPI and the loopback did the trick. My problem appears to be solved. Thanks again.