mute troubles

I have recorded 3 separate tracks, when I mute the 2 instrumental tracks and try and just play vocals, the 2 other tracks are still playing even though it shows muted.
its working for the instrumental tracks just not vocals and it was working yesterday

There are 2 different options for the solo/mute buttons …

Alternatively headphone bleed (of the instrumental) on the vocal track ?.

Maybe you’ve recorded the instrumental tracks into the vocal track. That can happen if you are recording from “stereo mix” or “WASAPI loopback” rather than from the microphone.