Music feedback when recording vocals

So I’m recording my vocals and using overdub but when I playback my vocals, I can still hear the beat and it has a faint bassline and it’s REALLY irritating. I want to know how to STOP that so I can get complete vocal isolation.

So you’re re-recording the backing track sound along with your voice. This problem is super common among people who like to record YouTube sound or other internet content. Those foldback settings run Record and Playback at the same time and link them. Those are exactly the wrong settings for overdubbing. Overdubbing depends on complete isolation between the two systems.

Do you remember how you set up your machine for internet capture? Most computers won’t on-line capture without special settings. Stop doing that. That’s not very useful, is it? The problem is each computer does it a different way and I can’t tell how you personally did it.

As a fuzzy rule, Audacity should be recording from a hardware, physical object, not a fake device or software program. For example, My machine would be recording from my USB mixer, an actual hardware thing I can touch and not SoundFlower, a software foldback program.

Let us know if we’re close.


You are using headphones, right? You should never have a live microphone without headphones.