Multiple Problems Since Upgrading to Audacity 3.4

I used an older version of Audacity (can’t remember which one now, unfortunately) for years with no problems. Recently, though, I upgraded to Audacity 3.4, and suddenly I’m having issues:

  1. Older files with .aup extension are no longer recognized and don’t open.
  2. If I understand the manual, in this new version of Audacity, if I want to record a separate vocal track over an instrumental track, I need to press Shift and click the Record button or hit Shift+R. However, I’m finding that both of these options start recording at the end of the instrumental track instead of in sync with it.
  3. Audacity initially recognizes my mic (Rode NT1 with Rode AI-1 interface) when I want to start a new single-track recording, but if I open an existing project and try to record an additional track for it, suddenly I get an error message: “Error opening recording device. Error code: -9999. Unanticipated error.”
  4. After recording a couple of new single-track projects, Audacity will randomly stop recognizing my mic and give me the same error message as above.

I’m on two older machines, a PC running Windows 7 and a Mac running Mojave, and I wonder if they’re simply not compatible with the new Audacity. Anyone know what the fix might be, or if there isn’t one, are there earlier versions of Audacity available to roll back to? I mostly record songs with separate vocal and backing tracks, so if I can’t continue to do that, Audacity is pretty useless to me.

Ok, so I rolled back to my very first version of Audacity, which was 2.0.3. This solved the issue with older .aup file recognition, but I’m still having issues with Audacity recognizing my mic. I’m getting the message that says, “Error while opening sound device. Please check the input device settings and project sample rate.” This was never a problem when using 2.0.3 before, but suddenly it is now. Any ideas? I should add that Windows recognizes my AI-1 interface and has the record sample rate set to 1 channel, 24 bit, 44100 Hz and the playback sample rate set to 2 channel, 24 bit, 44100 Hz. Audacity is set to record on 1 channel with a 44100 Hz project rate.

Or Hit R.

One of those record commands starts at the end of the existing track and the other begins a new track. If you are in love with them working backwards, you can make them backwards in Preferences.

The widely considered stable old version is 2.4.2.

Audacity has a pile of standards, settings, and preferences that don’t change when you do an up or down grade. That’s so you can slide gracefully into a version upgrade without remembering all your custom settings and adjustments.

That’s less good news when you hit some damage and the damage hangs around like the flu. You probably need to install version 2-something and then go in manually and reset everything to factory zero.

Another elf can tell you how to do that.

Koz

Thanks, friend. After playing around with the settings, I have a little more info for anyone who’s reading: The main problem seems to be with the settings under Edit>Preferences>Devices. When I have both the playback and recording device set to the AI-1 interface, Audacity can’t open the mic to record. If I change the playback setting to anything else (speakers, monitor, etc.), then I can record, but of course playback is through the selected device instead of my headphones attached to the interface. It’s kind of like Audacity doesn’t believe I can both record and monitor sound on the interface at the same time. This is happening in both versions of Audacity I now have installed, and it never used to happen before the recent upgrade and rollback. Any thoughts??

This topic was automatically closed after 30 days. New replies are no longer allowed.