Multiband EQ effect causes crash on Win7 home

Hi, the header really says it all. All the other effects - I have tested almost all of them, I believe - work 100% error-free. Only the Multiband EQ causes trouble - and that, every time. The tracks are not ultra long. I haven’t tried in short chunks yet, though. Might there be another, non-crashing Multiband EQ plugin somewhere?

Cheers, Henri

There is nothing in Audacity called “Multiband EQ”.
Do you mean this effect:
or something different?
If it is a different effect, please tell us where you got it from so that we can try it.

Hi Steve! It’s in one of the plugin bundles - I fail to remember which, but probably the large one. If you are Steve Harris, it’s one of yours. I tried it just now for a shorter chunk and it didn’t crash, so it works at least partially.

I’ll also check if there’s a fresh version of Audacity - mine is some months old at least.


I’m not Steve Harris.
It’s known that there are problems with some of the LADSPA effects, but not this particular problem.

Before you update Audacity, please look in “Help > About Audacity” and tell us the full version number.
The current version is 2.0.5 and you can get it here:

The more you can tell us about how to make it crash the better:

Windows 7 Home
Steve Harris MultiBand Eq
Tracks over … length (mono or stereo?)
Any particular settings?
Sample rate and bit depth of track?

Try the built-in Equalizer effect (link in my first reply).

Yeah thanks all - my version is old, I don’t think it has the Equaliser yet. Should have checked that first. Got all the answer I needed.


My problem has been solved but for general interest: mono tracks, length not exceeding 5 minutes I’m pretty sure (if they did, not by much) - no particular settings (not on that effect - it crashed every time and my tweaking was pretty random) - the whole project might have contained 8 tracks but not much more. I don’t remember the sample rate and bit depth but whatever you get straight off Tascam DP-0004 and such. 44100 and, um…? The computer is just a cheap, off-the-shelf eMachines laptop so that’s where I would look for the fault first, though.

Cheers, Henri

Was that by upgrading to Audacity 2.0.5?

Maybe; I’m not sure if the Equaliser effect already was available in the previous version - I think 2.0.2. If it was I hadn’t used it because the name has been translated into Finnish; I’m Finnish myself but I’ve only thought of EQ as EQ, not “Taajuuskorjain” - which is correct but not a regular term in my vocabulary. I wasn’t curious enough to see what that might be (if it was on the list). Now that I knew it was there, I started using my head a bit.


:slight_smile: I can see how that might be confusing.

This is sometimes an issue with translations. There is so much “technical” equipment and software released in English only (usually “American English” if you don’t mind the oxymoron), that people become familiar with the English terms. In some cases the English term is so widely used that it can be better to not translate the word.

Translations of the Audacity interface and manual is a huge, ongoing task. New volunteers to help with the task are always welcome. I can send you details if you have time and are interested.

Yes, the Equalization effect was available in 2.0.2. It’s been a part of Audacity since 1.3.something.

Why not - it’s a free, good software - I’ll help out whenever I have time.


You will find information about translating here:
If you have further questions about translating, send an e-mail to the feedback address (on this page: where it says “You can e-mail us”) and I’m sure they will be happy to help with your enquiry.