Multi Tracks

I need to be able to hear track one when recording track two. Not happining. I am using the SoundTech Light Snake USB cable from my digital piano to my laptop. I am using Windows XP with the 1.3 Beta version. I have tried checking the overdub (to listen while recording) and the playthrough options, also the input and output devices match. I have been reading the posts and have tried numerous things. Help! I have spent alot of time working on this and i need to get recording. Any Ideas? Thanks Chris

Just a note. Can you make a recording if you don’t go through all that craziness? Has the USB device ever worked at all in a straight recording?


yes I am able to record, I just can’t hear the previous tracks when i’m recording a new track. I have to disconnect the USB device to hear what i have recorded. I have looked in my windows control panel under “sounds and audio devices” to see if something was not turned on, but it looks good. Do you know of a better way to connect my piano and synths up to Audacity without using the USB Light Snake device? What do keyboard players use when recording with Audacity? Thanks for the reply. I hope this answered your question. Chris

You are using the USB light snake to record. What are you using for playback? Do you have the playback device correctly selected in Audacity Preferences (Audio I/O tab).