MP4 import issues even with ffmpeg and latest version


Hi there!


I’ve tried everything short of completely uninstalling and wiping all audacity folders from my computer but can’t seem to solve this issue. I tried all the instructions twice just to make sure, but can’t seem to figure out where it went wrong:

Even when I confirm the ffmpeg is correct and mounted, I get a scrambled screeching sound for every mp4 I try to import. Sample attached.

I viewed the Diagnostics>show log and didn’t really understand the majority of the messages, but it seemed to be correct. Attached here as well.

I’d appreciate any help I can get, and sorry if it’s a simple fix that I somehow have overlooked!
Screen Shot 2019-09-11 at 1.54.22 AM.png
log.txt (2.44 KB)

I confirm the ffmpeg is correct and mounted

How? There are two different FFMpegs now. One for 32-bit and one for 64-bit. It’s possible you carefully mounted the wrong one. Checking.


64-bit Libraries.

Did you allow your Mac to hide filename extensions? That’s probably a bad idea when you’re having troubles. This may look different on yours.

Screen Shot 2019-09-11 at 5.41.22.png
Where did you get your sound files from and do they actually have the .mp4 extension? Also, right-click on one and Get-Info.

How long are they? If they’re under 2MB, you can try to attach one here.

Audacity can’t make a video file.


Does that open in your Audacity? If not, you have the wrong FFMpeg.


Thanks for helping to trouble shoot:

I used this link to download a 64-bit ffmpeg: >> like it says on the official audacity manual.

Not sure if hiding filename/extensions affects how audacity sees the files, and it seems to be the correct one when I use the Preferences>>Library>>Locate feature in audacity to confirm it’s the correct ffmpeg.

I’ve attached a screenshot of an mp4 as example, and I’ll put a link for the original mp4 here. It was sent by a client that I’m dubbing over the video for.

It “opens” in audacity…but it create the screeching garbled audio file I attached above for any mp4 I import.
Screen Shot 2019-09-11 at 2.31.38 PM.jpg

It “opens” in audacity…but it create the screeching garbled audio

To back up a bit. I mean the little .m4a that I posted. We know yours have problems. Mine should be a short, mellow, 400Hz broadcast test tone. Is it?

Not sure if hiding filename/extensions affects how audacity sees the files

Now how Audacity sees them. How you see them. You wouldn’t be the first person to pound away at trying to open a file only to have it turn out to really be a foreign file type with a hidden file extension and no amount of pounding is going to open it.


Fascinating. It opens in the older Audacity 2.3.0 and two different machines internal video player but not in Audacity 2.3.1.

Screen Shot 2019-09-11 at 18.39.02.png
I think you’re going to wander right out of my field. I don’t have 2.3.2 on anything, or the updated plugins, so I can’t test this particular problem. But yes, it does appear to be technically correct and as I said, it does open and play perfectly on an older Audacity. Did you do updates between now and the last time this worked?

This will take me a bit to catch up. As we go.


Just to do it, I opened 2.3.0 on two different machines and the video opens and plays perfectly.

Screen Shot 2019-09-11 at 18.59.05.png
With honey crystals and brown rice…



Sorry for misunderstanding. Yes, the M4a you sent opens perfectly fine. I think I had this issue with the prior install 2.3.x but I’m not sure which it version it was. I just know it didn’t happen before I did the last two updates.

Would you recommend I find the 2.3.0 and see if the problem persists with the older version that works on your computer?

Not done yet. (Rolling up sleeves)

I just did a fresh install of Audacity 2.3.2 on my High Sierra 10.13.6 and installed the recommended FFMpeg. Now the video opens correctly in both 2.3.0 and 2.3.2. I would have put money on the new install crippling the older Audacity, but no. Both live.

I am opening the video by dragging it from the desktop into the open-and-waiting Audacity. If that how you’re doing it?

Screen Shot 2019-09-11 at 19.35.37.png
Did you get a bad download? 89MB. The string between me and the central office got hot.


The sound rate is 48000 standard for video and the show length is 1 min 11.68 Seconds.

Screen Shot 2019-09-11 at 19.40.14.png
I just hate it when I get toxic chemicals in my exfoliate.


Seems like when I drag it from anywhere (download folder, or desktop) or do an actual Import File from the menu bar it’s the same no matter what.

Interesting that when you import it says 48000–mine says 8000hz

Do you think it’s because I have Mojave instead of High Sierra?

Not a clue. I’ve been avoiding that last update step because Mojave does some really wacky things. The security is stricter and it’s possible Mojave is messing with the FFMpeg install. Even my machine asked me if I was Really Sure I wanted to install that software.

The senior elf is on holiday so this may take a bit of extended shuffling.


I realize that’s what it should be, but somehow when importing to my audacity it changes to 8000hz. What’s the next step. Complete uninstall and reinstall?

LOL. Senior elf!

Okay, I’ll keep working around it the “convert-before-import” way in the meantime until we hear from our vacationer.

On my MacBook Pro I run latest Mojave 10.14.6 and Audacity 2.3.2 (and the alpha test build for the upcoming 2.3.3).

This does not happen on my setup when I import .m4A files - particular I tested importing a couple from my iTunes library

a) one that I had created with peaks at about 0.5 (c -6dB) and

b) another sent to me by a musician friend - a saturated signal but overblown clipping
Screenshot 2019-09-12 at 09.22.44.png

It doesn’t affect M4As for me either. My problem is with MP4s

I don’t have any MP4s - do you want to post a very short on here for me to try ?


There is a dropbox of an actual presentation up the thread. That’s the one I used.

I never got the posted failure and sound damage. I got either success or nothing opened.



Senior elf!

We steal in in the middle of the night (your time) and mend your sound problems. What else would we be?