MP3 Exporting suddenly taking

I’ve attempted to solve this myself since last night, and I have run out of ideas.

Running Audacity 2.1.2 on Windows 10. Installed it via .exe file over a year ago. Have been using it as my primary workstation for podcasting and for recording my band with my focusrite iTrack Solo. I have had zero issues with it since I downloaded it.

Last night, after having successfully saved a 39 minute project mid-afternoon in 7 minutes (typical), I asked it to save a 47-minute project. It began climbing in save time, and never stopped increasing, the time got to around 180 hours to save the file in the little box (and was still climbing). I turned off everything, disconnected from wifi, nothing was running in background, and it didn’t go lower. I then cancelled, restarted the PC, and tried again. Same thing. I then deleted audacity, and freshly reinstalled it. Still the same results. I tried to start a new file, and the same thing happened to that file (and it was only 4 minutes long). I reinstalled LAME, and that did nothing. I ran a full anti-virus sweep, and that turned up nothing.

I am flummoxed. I have no idea what could be causing this. It defies logic since it worked fine and nothing happened between 2:45pm and 9:30pm yesterday as the computer was turned off.

Does anyone have a fix for this, my music projects and my podcasts are effectively on hold until I can figure this out!

Thank You!

I believe it does that if you have greatly mismatched tracks on the timeline. The time display is lying to you. The actual export should work OK.