Monitoring USB turntable

Recently purchased a USB turntable. Yesterday everything was working great. Recording while monitoring, editing, and exporting. Came back to my work this afternoon and Audacity didn’t even recognize the turntable at all. Something about Sound Mapper being missing. I could get another editor to record, but still no monitoring.

Any suggesting getting Audacity working again?

A couple of things can happen…

If you don’t plug-in the turntable before starting Audacity, it won’t know there is a USB device. But if Windows sees it, you should be able to select it as your [u]Recording Device[/u] after restarting Audacity.

If Windows doesn’t see it, you may have a bad USB cable… Or some other problem…

For monitoring, Windows and/or Audacity may be trying to play-back through your USB device so make sure you’ve got your soundcard (or whatever you listen through) selected as your Playback Device.

Thanks but none of those apply. Windows does see the USB Codec input/output. IN control panel, USB is Input and Realtek Speakers as output. Also shows in Audacity correctly as recording device. I have other software that can record from the USB turntable, but I can not hear what is being recorded. Another software is like Audacity, nothing happens. As I posted earlier, everything was working perfectly yesterday including monitoring the recording. Tried in on my laptop which has never had any editing software. Same thing - can not record at all with Audacity. I’ll be sending feedback to MS.

I’ve read many posts here and other forums, seems like Win10 has many issues with USB audio devices - just not turntables.

Any others suggestions? When I open Control Panel / Sound / Recording Tab, the USB Audio Codec is set as default. When I place the stylus on the record, I DO see the meter in that dialog move. So Windows is recognizing the turntable USB input.

I installed the 64bit version of Audacity 2.2.2. Would that be an issue?

I am having the same, or very similar, issue:

  1. I have been using the same audio-technica usb turntable, with the same Windows 10 PC, for over a year with no issues.
  2. About 2 months ago I ran into the same problem I believe you’re having. At that time, I was able to somehow get it working again - rebooting, deinstalling and reinstalling Audacity, etc. - not sure what eventually “fixed” it at that time.
  3. Yesterday, I used Audacity for the first time since then and ran into the same issue again: Audacity recognizes the music coming from the turntable - meters register and it records because I can save the file and then listen to it through Audacity. However, I cannot monitor the music while it’s being recorded.
  4. Updating from 2.2.1 to 2.2.2 made no difference.

If I find resolution I will certainly post it back here…