Monitoring from vinyls.

I have an older Ion usb turntable, which I bought in May 2007. I used it successfully then, in Windows XP, using the Audacity software of the time – I forget the version number. As now I was recording from vinyls to cd.

I have now returned to do the same thing, and have upgraded Audacity to v.2.0.5. using Windows 7 Home x64. I have not yet tried recording, but in setting up have been playing via. ‘start monitoring’. The only reset I have made was to reduce the ‘input volume’ to 0.66, because of distortion.

I am finding that the monitoring function is intermittent. Once it is going
it is OK, but often after I have closed down I can’t get it going again,
and when I do so I’m not sure how. I at first thought that it might be a
poor connection with the usb lead, and when I ensured that it was properly
plugged in it went OK, but thereafter it either works or it doesn’t. I have
tried uninstalling and reinstalling Audacity, but without any change.

I happened to have a spare usb lead, but that gave no improvement. I have also checked the continuity of both leads, and that is OK.

I tried downloading ‘EZ vinyl tape converter’, and that seems to work. That indicates to me that my problem is not with the player, or the connection, but with the Audacity program.

Does anyone know whether there might be some bug in the program, whereby it is not properly geared to the older Ion usb turntables?

I would be grateful for any advice,

Did you try Windows’ equivalent of software playthrough as I suggested on feedback@?

Right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the USB turntable, then choose “Properties”. Then click the “Listen” tab and enable “Listen” so as to send the input to your built-in computer sound device. You can then turn off “Software Playthrough” in Audacity.

I don’t know how EZ works, but in Audacity you could try Edit > Preferences, choose “Recording” on the left, and increase “Audio to buffer” above 100 milliseconds.

Make sure your playback device in Device Toolbar really is the computer sound device. Choose it by name, such as “Speakers”.

Use 44100 Hz project rate bottom left of the Audacity screen.


Thank you.
Yes, I did as you said; apologies for not replying to that. When I go to ‘Properties’ I get the ‘Sound’ menu. I don’t get ‘usb turntable but I do get ‘Digital audio ( S/pdif), which I assume is the turntable since it disappears when I disconnect the cable. Anyway, when I hit ‘Listen’ there is no improvement, whether ‘Software Playthrough‘ is on or off.

In Edit > Preferences > Recording, the Audio buffer was at 100, I increased it to 150 and 200 without effect. The ‘Project Rate was already set at 44100 Hz.

The Devices toolbar is showing ‘Digital audio (S/pdif).

I don’t like ‘EZ vinyl tape converter’ much, as it doesn’t have the control features as does Audacity. Also, it produces .wav files, that have to be converted to mp3 or such before I can record to disc. However, it does show that my Ion player is feeding signals to the computer.

S/PDIF should not be your turntable. It should have “USB” and probably “CODEC” in its name.

To use Windows “Listen to this device” to send the turntable to your computer speakers, you must do the following exactly. No changes to the steps. Right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the USB turntable, then choose “Properties”. Then click the “Listen” tab. Put a check mark in “Listen to this device”. In the drop-down “Playback through this device”, choose the computer playback device you are using. Don’t choose S/PDIF for your playback device unless you actually have speakers connected to S/PDIF of the computer.

Don’t forget to click OK. You can then turn off “Software Playthrough” in Audacity.

Is that the output device (second box)? Don’t choose S/PDIF for your playback device unless you actually have speakers connected to S/PDIF of the computer. If it’s a laptop computer, try choosing speakers or headphones as appropriate.

The input box (third box) must be set to your USB turntable because that is what you are trying to record from. This should normally be USB Audio CODEC. If you do not see USB Audio CODEC in the input box, restart Audacity.

If you want to play the CD in a standalone CD player like in a car or in a boom box (music centre) then you want to burn an “audio CD” and to burn the CD from WAV, not from MP3. The CD burner will expand the lossy MP3 files without improving their quality, so burning MP3 will just give you an inferior sounding audio CD without giving you any more playing time.


Thank you,
OK, did that, & turned off ‘playthrough’. The ‘usb/codec’ name in the audio tab is attached to ‘microphone’, which put me off that setting.
This is a desktop computer.

Settings now are:
In the ‘Listen ‘ tab, have ‘Listen to this device’. I have selected Speakers (usb audio codec).
‘Software Playthrough’ turned off.
‘Input and output devices’ both set to ‘usb audio codec’.
‘Audio Host’ MME.
Input channel ‘mono’.
The ‘output volume bar is at 0.99, input volume 1.00.

So, the ‘Input Level’ meter is now showing sound (the vinyl is mono), but no sound is coming from the speakers. Also, the usb/codec volume bar in the ‘speakers’ tab is showing input. The speakers are operating OK with
on-computer music (Itunes), and also from commercially recorded cd.
I am not seeking to record yet, whilst trying to sort this out.
Ultimately, I shall want to play any recordings on computer only.

Unless you actually have speakers for the computer that are connected to a USB port on the computer, “Playback through this device” on the “Listen” tab must be set to your built-in audio device. This is either your built-in computer speakers, or if you don’t have built-in speakers, it is the device which you use to listen to audio in iTunes. For example, this may be speakers or headphones that are connected to the green audio out jack on the computer.

Again, the output device must be set to the device that you use to listen to iTunes.

If any of your records are stereo, you’ll have to go back to the “Recording” tab in Windows “Sound”, right-click over the USB Audio CODEC for your turntable, choose “Properties”. On the “Advanced” tab, in the “Default Format” section, make sure the drop-down menu is set to “2 channel 16 bit 44100 Hz”.

OK but be prepared to turn the input volume down if necessary. The top and bottom of the recorded waves should not go much over 0.5 while you are recording.

See above.

It may be an idea to look at this page in the Manual if you have not already done so:
Recording with USB turntables or USB cassette decks . You can use the File > Print function in your web browser to print that page out if that makes it easier.