Monitor voice recording with earphones

I had been using garage band but no longer have access.
I want to use Audacity but there is a slight delay of my voice in the earphones.
What may I do the solve this issue.

You lost your Mac and now you’re using a Windows machine.

You’re listening to machine latency. Your voice is coming out “one computer late.” The only way I know to work around that is plug your headphones into your USB microphone or USB microphone adapter.

If you’re keen on computer programming and compiling programs, you can recompile Audacity with ASIO support. ASIO can provide greatly reduced echo when you listen in your computer headphones. Unfortunately, Audacity cannot be supplied with ASIO built-it because it’s somebody elses software. Same reason we can’t supply Audacity with MP3 generation built-in.


Thank You! Send me your email address and I will send you a complimentary audio book!

I deleted your email address. It’s a terrible idea to post a hot email address on the forum because of grazers, harvesters and spammers. It’s a good way to wipe out your address.


Plugging my headphones into the mike solves the delay but I can not get enough volume
in my headphones! It there a setting on the software. I have tried all I can think of.

It there a setting on the software.

The whole idea of plugging your headphones into the microphone or interface is that the sound doesn’t go through the software. Zero Latency Monitoring. There are no settings to cause delay and echos.


There is a hardware fix : a headphone amplifier , or a cheap mixer.