MLP to WAV - all I get is hiss

I don’t know any softawre that can burn CD’s directly from MLPs so I’m trying to convert my MLP audio collection to WAV so I can later burn CDs to listen in my car.
My MLPs are ripped from my DVD-Audio discs so they are 24-bit, 96.0 kHz and usually 6 channels. Since I can’t import mlp as audio I have to import as raw data - these are my import settings (attached screen). When I play the track in Audacity after import all I hear is hiss. What am I doing wrong?
BTW I want
Snapshot 2021-11-07 16.04.38.png

Raw won’t work with any compressed format. When you import as raw data it will be treated as uncompressed PCM so the MLP won’t be decoded and you’ll get “garbage”.

Do you have FFmpeg installed? FFmpeg is supposed to support MLP but of course it has to be decrypted. (Audacity is using a older version of FFmpeg and I don’t know if this version supports MLP. And currently there is a bug with multi-channel importing so you might have to use an older (32-bit?) version of Audacity.

Can you can play the file in VLC? If so, it should be able to [u]convert[/u] to WAV or FLAC.

Otherwise you might have to find a different ripping application. Most ripping applications can convert to a variety of formats, but DVD-Audio was never popular so I don’t know what’s available. (And any software that cracks the copy protection is illegal.)

As a “last resort” you can [u]record it as it’s playing on your computer[/u]. Or if you have a regular soundcard or an interface with a line input, you can record the analog output from your DVD player or receiver. (The mic input on a laptop is not “correct”.)

Thank you so much for a prompt and comprehensive reply.
I’ve tried VLC conversion and it worked but when I go Media > Convert / Save > profile settings (screen) the default bitrate is only 128 kb/s and you can change it to 512 max (screen). For all I know for audio CD quality I need 1,411 kilobits per second so it seems that VLC cannot achieve that and I have to try one of the other options you suggested.
max bitrate.png
vlc settings.png

Media > Convert / Save > profile settings (screen) the default bitrate is only 128 kb/s and

Yeah… That’s not “CD” or a regular WAV file…

I don’t have any MLP files but I’ll try some things to see what I can get…

Go ahead and try it. It seems to ignore the bitrate setting for “CD”. I converted a VOB file from a regular DVD and I got a valid 16-bit, 44.1kHz, stereo WAV file. BUT, it’s badly clipped so the mix-down isn’t working “correctly”. Where it’s not clipped it sounds OK. If your MLP is stereo you should be OK.

A 6-channel WAV was OK but identifying the tracks for mixdown might be tricky. And if this is one-long file you might exceed the 4GB WAV limit with a multichannel file.

FLAC didn’t work for me.

Thank you DVDdoug
I also posted on VLC forum and they replied that the bit rate field is purely advisory for the encoder and since the WAV codec is uncompressed, the bitrate is entirely defined by the samplerate: 44.1 kHz * 2 channels * 16bits/sample = 1,411 kbs
I’ll stick with VLC then.
Thank you very much for your replies.