Mixer Toolbar Greyed Out, needed driver[SOLVED]

Version 2.0.3 , have followed the instructions from Audacity, but getting nowhere, my recording device shows under windows that it is microsound mapper, cannot preceed to get sound

Please explain exactly what device you are trying to record from, and how that device is connected to the computer.

If you are recording from a USB turntable or cassette deck, please read this page thoroughly as it solves most questions and problems:
http://manual.audacityteam.org/o/man/recording_with_usb_turntables.html .

If the sound you want to hear is the sound that you are recording, choose Transport > Software Playthrough (on/off) in Audacity so that it is on (checked). Then in “Output Device” in Device Toolbar choose your computer playback device by name (probably Speakers or Headphones). Do not choose Microsoft Sound Mapper - Output.

If you are trying to control the loudness of what you are recording and the right-hand (input) slider in Mixer Toolbar is greyed out, right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the device you want to record from then choose “Properties”. Then click the “Levels” tab and adjust the input slider there.


Recording from turntable with 3.5 mm plug to line in, it had worked before very good.
The input device & input channels are blank with nothing in the drop down.
Output device set on speakers, audio host set on MME.
Nothing happens when I right click on speaker icon, do not get recording devices menu.

Does the disc have to be in & recording when tryin to monitor, or get the mixer control to work? Windows Media Player comes up asking for options also, to record, is this normal?

I got the mixer toolbar to refresh by going to transport/rescan audio devices, & they are not greyed out, however still no sound when I click on start monitoring.

Are you connecting the turntable to a phono amplifier or boom box/Hi Fi, and then connecting the amplifier or boom box to the line-in?

You should not connect the turntable direct to the computer. See here:
http://manual.audacityteam.org/o/man/how_to_connect_your_equipment.html .

Are the input device and input channels still empty? If not, what choices are in the input device box?

To record from line-in, you have to select it as input device in Device Toolbar.

OK so using Software Playthrough you should be able to hear any input that is coming in, assuming you have the output slider turned up in Mixer Toolbar and that you have not muted the system audio. If you can hear a song in Windows Media Player then you have not muted the system audio.

You must play the record or you will just be monitoring background noise in the system.

The Mixer Toolbar input slider should be available without playing, monitoring or recording. But if Audacity cannot control the input level, the Mixer Toolbar input slider is greyed out and you must set the input level in Windows “Sound”.

Here are details of what you should see if you if you right-click over the speaker icon by the system clock and choose “Recording devices” in Windows “Sound”:
http://wiki.audacityteam.org/wiki/Mixer_Toolbar_Issues#vistacp .

You can read in that link above how to enable the Line-in and other devices, if Windows has disabled them. If Line-in is disabled in Windows, Audacity will not list it in Mixer Toolbar.

You can also read there how to change the input level of Line-In (on the “Levels” tab).

Please check the link above or try accessing Windows “Sound” through the Windows Control Panel.

Windows Media Player can play songs or record (burn) a CD from a WAV audio file. It cannot record songs from an LP.


It is from turntable direct
input & device is on to line / device is on to 2 stereo input
Windows Media will play previous recorded music
software playthough is turned on
have played record
playback on Windows sound has a green check by speakers
recording on Windows sound has a green check by high def audio device

Choices are the following for When Windows detects communication activity
1 mute all other sounds
reduce volume of othersounds by 80%
reduce volume of other sounds by 50%
or do nothing

So is it a USB turntable? If not (it’s a standalone conventional turntable), that is supposed to be connected to a phono amplifier.

If you connect a standalone turntable direct to the computer, the Equalization will be incorrect (sound “tinny”). That is fixable in Effect > Equalization but the recorded level will be very low if connecting to line-in because the signal from the turntable requires pre-amplification. Are you sure this is not the reason why you can’t hear what you are recording?

Can you hear the recording if you record, CTRL + A to select all the recording then Effect > Amplify and click OK? This makes the recorded audio as loud as it can be.

Set that to “Do nothing”, but it should not affect recording from line-in, only possibly a recording from the microphone input.


If I contact Microsoft, what do I tell them to look for? I am getting the feeling their Win7 may be holding back the input somehow.

Microsoft spent a couple of hours by remote checking things out.
After downloading Vista & XP Audio drivers to try to get it to work, as a last resort they…
found the manufacturer (Realtek), choice of 2 devices to add to hardware…
then added the hardware to the pc, then I could hear audio.
It went something like this for my Gateway pc.
Under Device Manager/ high def audio device/ properties/ details / device description / hardware ids/ copy
then I think they somehow downloaded it, happened fast. (found under pcdatabase.com/vendor)
Under a long list, mine was 0880, installed specific driver for hardware from the maker.
The driver version is now 6.1.7601.17514 (right clicking on some of the above directions)

Important Note: AOL could not handle the downloads, had to go to Internet Explorer


So can we mark this as solved, that it was a driver problem?

It sounds as if Microsoft gave you a generic Realtek driver that is not really matched with your Gateway computer. This is why they were reluctant.


Yes, I am still struggling with burning & completing the last 2 steps. I read in the manual to only use the generic driver as a last resort.

OK. Thanks for starting a new topic for that :wink: