Mix and Render problems

You’re right I guess there’s nothing more without having other people experiencing the same thing, but I will say that what seemed to fix it was one of the earlier replies, the gaps, the stereo to mono and throwing away preferences didn’t help but so far filling in the gaps with silence has worked, and it hasn’t done it anymore so…that’s it. Posting this because this may be helpful to say if it does happen to someone else. And I’ll leave it alone now… Thanks

Then maybe your sound device cannot cope with suddenly starting an audio sound when other sounds are playing?

Why not post your audio device info as suggested so we have some information to go on about what playback device you are using?


I’m using a Roland SP-555. I use it as my main output and input device for all of the audio on my computer. I use Audacity to edit samples and record them to use on the SP. At this point I’m thinking the SP must be the issue sense no one in the world seems to be experiencing it. It would be great if there was an answer because I obsess over anything weird my computer does, spending hours trying to solve it but I’m putting this to rest and, at least for now, the filling in the gaps has been working. Either way, I use Audacity constantly and think it’s amazing that it’s free.

If you obsess about fixing it then perhaps you should do what I suggest about the Audio Device Info.

You probably do need to look at buffer lengths and sample rates. Try increasing the former (look in the Audacity Recording Preferences) and setting the latter to 44100 Hz or 48000 Hz (the Audacity setting is in the Quality Preferences at Default Sample Rate - that rate is then visible as the project rate bottom left in all new projects).

Then make these settings the same everywhere (Audacity, Apple Audio MIDI Setup and in the Roland settings if there are any).

Does GarageBand have the same problem?


Well, at this point I’m beginning to feel like a nuisance and so far filling in the gaps by joining parts of a track has seemed to work. The only similarity that I can think of is every now and then when when I’m using Skype, I hear a strange sound, that gradually increases in volume, that sounds like wind or a distant airport and then it stops, but isn’t a buzzy sound and it’s not nearly as loud. I looked all over the internet for the best settings when using the SP-555 with Audacity, because there’s no way I’m the only one doing this, and found nothing. I use Logic, Kontact, Reason and I’m learning Abelton Live, and with those I never experience anything like it. I was going to increase all of my Mac’s audio output to 48000 but in my audio/midi preferences the sp-555 sample rate is fixed at 41000 and can’t be changed, but I was able to increase the buffer size, there wasn’t an option to enter or adjust by a numeric value, only a slider to increase or decrease. I guess I’ll have to keep all of the system output sample rates the same like you said I should do. In Audacity I increased it to 130 and the latency to 0 because I looked all over the internet for an ideal setting and that was the only recommendation I could find. Something else I think forgot to mention is that whenever the loud buzz happens while I’m using Audacity, lowering the system volume does nothing.

Did you try trashing the preferences file?
– Bill

OP said in https://forum.audacityteam.org/t/mix-and-render-problems/29467/19

throwing away preferences didn’t help



I searched & found this topic because I have a similar (maybe the same) problem. It’s not really a huge problem for myself (I can fix it by exporting the individual tracks and create a new project with those) but maybe this information may help figure out what the problem is?

My setup is:

  • macbook pro, 2.3 Gbz Intel core i7 - osx 10.8.3

  • audio devices: (not sure if this is of any use, I’m pasting it here just in case)
    Built-in Microphone: Channels: 2; Current SampleRate: 48000
    Built-in Output: Channels: 2; Current SampleRate: 48000
    Soundflower (2ch): Input Channels: 2; Manufacturer: ma++ ingalls for Cycling '74; Output Channels: 2; Current SampleRate: 44100
    Soundflower (64ch): Input Channels: 64; Manufacturer: ma++ ingalls for Cycling '74; Output Channels: 64; Current SampleRate: 44100

  • Audacity 2.0.3, Project rate 44100

I experienced this distortion problem while creating a project with three stereo tracks, all of which were copied from .wav sound files (16 bits/sample / rate: 44100).

Here’s a screen dump of the project:

This picture already shows the whitespace replaced with generated silence, although this did not help in my case (and neither did trashing the preference files).
The distortion (sounding kind or rhythmic, as coming from a broken speaker) starts around 15 seconds and lasts until 35 seconds. Funny enough, the distortion is gone when I mute two of the tracks, but it returns when there are (any) two or all three tracks active.

What did help, was to export each track individually (as AIFF files) and import those in a new project.

I made a mp3 export: one using the original project (with distortion); the other one of the new export->AIFF->import project.
It’s the first part of the project from about 8 seconds to 45 seconds: the distortion starts around 8 seconds into the file.

not distorted

If it is any help, I’m happy to share the project- and/or source files.


Thanks, Luthien for the details.

If you open Audio MIDI Setup in your Applications/ Utilities folder, and set the Built-in Output to 44100 Hz, does that help?

If not, does choosing another output bit depth in Audio MIDI Setup (to right of the sample rate box) make any difference?


Hi Gale,

thanks for your reply.
I just tried with the output set to 44100 Hz, but it doesn’t make any difference; and neither does any of the other three available bit depths.

(just to make sure: I only changed the Audi / Midi settings, not the Audacity project settings: that’s 44100 Hz / 32-bit float on all three tracks.


If the project is only about 4 minutes or so and you can make it available online (dropbox, adrive.com, minus.com or similar), then I will try it out on a Mac mini - but I am not optimistic I will find a problem.

Please look at File > Check Dependencies… and copy in any files the project depends on. Then set the project in a state it distorts, save and close it, then make a zip containing the AUP file and the _data folder.

Have you had this problem before, or is this the only time? Do you think Soundflower could be something to do with it (have you added it recently)? I know you are not using Soundflower for Audacity output?




I trimmed the project to the part that has the distortion issue. This did not affect the distortion.
Then I saw the menu option “Save compressed copy of project…” and tried that. This project turns out to NOT have the distortion issue :open_mouth:

I zipped both versions and uploaded them to dropbox here
The one called distortion-c.zip - the original, non-compressed version - has the distortion starting at around 16 seconds, to about 32 seconds. The other - distortion-c.zip - doesn’t. At least not here. Note that that re-assembling the project from exported (.aiff) files did not have the distortion either.

Have you had this problem before, or is this the only time?

No, this is the first time. But I haven’t created a lot of multiple-track Audacity projects before, so it is possible that the issue has been there for a longer time, but that I just never encountered it.

Do you think Soundflower could be something to do with it (have you added it recently)? I know you are not using Soundflower for Audacity output?

I’m not sure. I can’t really tell whether mixing those two bit rates (44.100 & 48.000 Hz) could have this sort of adverse effects - possibly in an indirect manner? But since setting it all to 44.100 Hz did not make any difference - while using the different file formats (in creating the .aiff based duplicate project, and also in the compressed .ogg version) made it disappear, this seems to suggest that maybe there’s something with how the system deals with .au files?

I used Soundflower for input on Audacity: I wanted to record one of the osx system voices. Therefore I re-routed the osx audio output via Soundflower to Audacity’s input.

Yesterday I experienced some other unexpected effects while applying effects (some random portions of the audio got wiped) - but I better put them in a separate post.


The one called distortion-c.zip - the original, non-compressed version - has the distortion starting at around 16 seconds, to about 32 seconds. The other - distortion-c.zip - doesn’t.

Typo - this should read

The one called distortion.zip - the original, non-compressed version - has the distortion starting at around 16 seconds, to about 32 seconds.
The other - distortion-c.zip (compressed version) - doesn’t.

When saving a “compressed project” each track is rendered as an OGG, then decompressed when reopening the project.


I tried the project on Windows and Mac - the issue is repeatable but the problem seems to be confined to that bottom track that has the claps. The problem goes away when you save a compressed project (which exports OGG files) or export other formats because by default dither is being applied. If you turn dither off under “High-quality Conversion” in Quality Preferences then the problem is still there in the exported files.

One thing I don’t quite understand. If you use the Track Drop-Down Menu to change the sample format of that track to 16-bit then play the project, the noise goes away (whether real-time dither is on or not).

So have you got the original WAV for that “claps” track? Import it into a new 32-bit project on its own and see if it makes the noise. I expect it will, if so it is not a problem of mixing or offset tracks.


When changing the bit format from the drop down menu, the “High Quality” conversion settings are used.

The buzzing noise is due to NaN values for some of the samples in the third (hand clap) track.
NaN (Not a Number) is not a valid value for audio samples.

Yes indeed, though I was assuming when playing back that there would still be resampling because there would be a mix of 16-bit and 32-bit tracks (and so high-quality dither off, real time on would still cure the noise issue). But perhaps the mixing is done after the resampling?

@Lúthien, when you said these WAV files were copied, do you mean they were originally recorded by SoundFlower?


The conversion from 32 bit float to 16 bit occurs “while you wait” (using the High Quality settings, but still very quickly) as soon as you select 16 bit in the drop down menu.

Probably my question wasn’t clear. What I am getting at is - what sample format conversions are going on when we play two 32-bit tracks and one (already converted) 16-bit track and the Quality Preferences are 32-bit?

If the 16-bit track is being upconverted to 32-bit (or left as 16-bit for playback) then no dither should be applied to it. Thus if the 16-bit track was converted with High-quality dither “off”, it will not have its NaN’s corrected in playback, even if real time dither is “on”.

But what I thought might happen is that the 16-bit track gets played at 32-bit and then downsampled to 16-bit (as it would be upsampled then downsampled if an effect was applied to it).


The first one.
I’m unsure whether the 16 bit track is converted to 32 bit float or not, but that would be no more than a technicality. Conversion from a lower bit format to a higher one is perfect (lossless), and there would be no need to convert back to 16 bit because the audio is only being played and not written back to a track. It’s the initial conversion from 32 bit float down to 16 bit with shaped dither that “fixes” the NaNs.

The $64,000 Question is: where are those NaNs coming from?