Mix and Render not working

Using Audacity 2.3.1
Dell Inspiron 15 7000
Intel i5 7300hq (at the time of this recording was running 8GB RAM)
Windows 10 (version 1809)

I originally thought I was having issues exporting a three-track .aup file to .wag or .mp3 (recording is a podcast). The progress bar of the export would go about three-quarters of the way then disappear, however, the file would not show up in the destination (external HDD - which has worked on multiple recordings previously). The export does show up in the “Recent Files” section of windows explorer, but when I would click on it, the media player would say there is nothing there. (I’ve made sure the “Hidden Items” checkbox is selected when viewing the external HDD).

Some Googleing led me to try and Mix and Render the three tracks to one before exporting, but when I do that, it again gets about three-quarters of the way through and disappears, resulting in nothing happening.

I’ve made sure that both LAME (3.99.3) and FFmpeg [F(55.33.100), C(55.52.102, U(52.66.100)] libraries are located.

I tried exporting the second and third tracks independently and those work. That leads me to believe there is an issue with the first track.

During the recording of the podcast, the whole PC froze. Was only running Audacity and Skype. Hard restarted and re-opened Audacity. Did the automatic restore option when it popped up and everything seemed to be restored. Continued recording and finished the project. All three tracks were recorded separately and imported into one project. I’ve since made standard silence, timing, and amplify edits (standard for the previous episodes).

Could the first track have been corrupted at some point during the crash and is now the cause of my export/mix and render issue?
Either way is there a solution now to export my final product?

Based on your post, it seems that the second and third track can be handled normally and reacts normally. The fact that the PC froze during recording and the first track seems to be the odd ball, corruption of this track seems a likely target.

So, can you load just this first track and play it?
Does it play through completely without problem?

If it plays normally and completely then you might try copying all of the audio and paste it to a new track. This may create an un-corrupted track. Delete the original track and save/export this new one and it may be okay. If it exports without problem then you should be able to reload all three files again and complete you project. If the first track gets weird and will not play, the its sadf to say it’s corrupted. Finding exactly where it is corrupted and how may be a challenge, but playing the file should give a clue.

Nailing down where the file is defective is the first step to salvaging it.


The file was playing through ok, it seemed. I tried the copy/paste thing and it still didn’t work. I played through the section of the crash multiple times and I couldn’t see or hear anything that didn’t sound normal. It wasn’t until I checked the log that I found a “20:28:33: Warning: Expected to read 262144 samples, got 0 samples.” that I realized the “corruption” (if that’s what I should call it) occurred during a quiet moment of the track. I selected that section and just generated silence. Immediately after the rendering and then the export worked.

Thank you Tomtt2 for the help and pointing me in the right direction.

Do you still have a backup copy of the project from before that correction?
If you do, that could be very useful for the Audacity developers to find out why the crash occurred and prevent it in the future.

Mstew, Thanks for passing your results along. It may come in handy in the future.

Steve, I do still have the original track before any edits. Roughly an hour and a half long. I’d be happy to send along the AUP file with a little direction as to how to send it.

Do you know how to make a “ZIP archive”?