Missing top bar on Audacity 2.0.0

Hi. I’m running Audacity 2.0.0 on Kubuntu 12.04, installed via repository - and I’m having some issues which I’ve been unable to resolve, despite completely purging audacity and all its associated files from my machine, and reinstalling.

On the top of the display, should be a bar containing dropdown menus, such as File, Edit, Tools, etc. On my system, it is missing. I can recover it briefly if I edit preferences, go down to keyboard, click the box for setting a new key combination, and selecting “OK” - but when I close the GUI and restart later, the bar is gone again.

It’s kind of getting in the way of my work, since I use that bar a lot, generating tones and suchlike, and was wondering if there is any way whatsoever of adjusting something in audacity’s configuration files to make that bar appear, or if it is possibly a fault with the version in Kubuntu’s repository.

Your help would be welcomed. Thank you :slight_smile:

I too run Audacity, the nightly builds, and I do not have the menu bar (File, Edit, …) when I open the application. I have tried (after reading other forum posts) deleting the audacity.cfg file in the .audacity-data directory. I am running the classic gnome desktop and not unity (My OS is Ubuntu 12.04 Precise, Gnome 3.4.1, Kernel Version 3.2.0-27-generic-pae).
What makes me curious about this is I have the exact same OS and Gnome and everything exactly the same on my Laptop and Audacity runs and has a menu bar.

Should I file it as a Bugzilla?

I appreciate and agree with Barkingfish, Its an annoying little fault.

Are you (both) talking about the main Audacity menu at the top of the main Audacity window?
If so, are you having the problem where the menu disappears leaving only the letters “Fi” (the start of the “File” menu) visible?

If that’s the case, the problem is due to a bug in WxWidgets 2.8.12 (which Audacity uses) and there is a patch available to fix it: http://trac.wxwidgets.org/ticket/13280
The Ubuntu maintainers are aware of this problem and of the fix, so I’m surprised if they have not yet fixed it.
The workaround for this problem is to resize the main Audacity window and then the menu should reappear.

If this is not the issue, please give more details, preferably with a screen shot to illustrate the problem.

Same issue here. I am using Zorin 6.0. If you use a old windows trick you can get to the menus. ALT-F and then your arrow keys. I know this sucks but it does work

Right - the issue is not that I’m just getting “Fi” on the top, and everything else blank - the issue is quite simply, the whole of the top bar has gone, period, and no amount of jiggling with controls other than what I stated in my OP, is bringing it back. I need that bar there, as I have memory issues due to severe epilepsy, and my rememberance of the various key combinations in order to do certain things I need frequently (tools, noise removal, equalization, etc) is completely non-existant.

Screenshot attached, as requested.

See if this thread helps:

If not, the problem could still be related to the Widgets bug Steve mentioned http://trac.wxwidgets.org/ticket/13280. In that bug, the menu disappears (except for “Fi”) If you open and close Preferences. Ask their opinion on the Kubuntu forum. If you need to patch Widgets, steps like these should work http://wiki.audacityteam.org/wiki/CompilingAudacityForBeginners#simple (you will have to patch Widgets after step 3).


I have exactly the same problem using gnome under ubuntu 12.04. Control/N brought it back. As there is no screen shot on the audacity web site (that I saw) it was rather confusing at first to understand why I couldn’t do anything.

There is a picture of a typical Audacity window on the front page of the current manual: http://manual.audacityteam.org/manual/help/manual/

On Ubuntu with the Unity Desktop it will look somewhat different because Unity moves the menu out of the main application window to the top of the Desktop.

For the solution to the similar problem in Ubuntu 12.10 64-bit, see https://forum.audacityteam.org/t/menu-problem-under-ubuntu-12-10-solved/27063/2 .