Missing option to build with internal sqlite library

Hi all

I built audacity 3.0.0 from source (as I have done for previous version) and I’m hitting the bug

Internal error at DBConnection.cpp line 275.

which is biting other people, as I saw in this forum. As I am using sqlite 3.34.1 and audacity developers test with 3.32.3, I assume the problem lies with my sqlite versinon/compile options. Now, as other packages are fine with sqlite 3.34.1, I’m reluctant to downgrade my local sqlite installation, but instead force the audacity build to use the bundled copy in lib-src/sqlite. However, I cannot find a documented cmake option to specify one?

How can I force the audacity build to use the internal copy of sqlite instead of the system one?


On Debian based distributions you can remove the “-dev” packages for the system versions. The -dev packages contain the software headers and are only required when building. If the system -dev packages are not available, then Audacity will build with the local version.

Alternatively I think you can also use:

cmake -Daudacity_use_sqlite=local ..

Thanks a lot for the answer, this did the trick, and I also got rid of the bug:

Internal error at DBConnection.cpp line 275.

However, after saving a project, closing and re-opening audacity on any aup3 file, I still get

“Failure parsing project information”

Will look into that later, for the time, I’ll downgrade to 2.4.2 again. There are some reports on that bug, too, maybe I find a solution.

Is that the exact message?

No, the exact message is “Unable to parse project information”, see the attachement.

As for the debug log: How can I enable that?


There’s not currently much debug information relating to the database.

To access the Audacity log:
“Help menu > Diagnostics > Show Log”

More debug information is available when launching a Debug build from a Terminal, but still not much re. the database.
To create a Debug build, use:

cmake -DCMAKE_BUILD_TYPE=Debug ..

Audacity 3.0.1 will contain more debug information relating to the database (this is being added now to aid investigation of this type of problem).
The latest development source is available from GitHub: https://github.com/audacity/audacity

I’ve found some information re. “Unable to parse project information”
I’m reading through it now and will get back to you.

What’s your OS?

The “Unable to parse project information” error has been identified in FreeBSD and fixed in the development code: https://github.com/audacity/audacity/commit/1bbfd3db5e5ed2f9f1700ffe5bc9bf269677f496

My OS is Linux, self-compiled, based on LinuxFromScratch/BeyondLinuxFromScratch

Anyway, I now build audacity git master, with -Daudacity_use_sqlite=local, and everything is fine now, both old and new projects save and re-open fine.

Thanks a lot for your help!

You’re welcome. Thanks for the update.