Missing font?

Hi everyone -

I’m a long-time user of Audacity on Windows, OS X and Linux but I’m stumped by this issue.

I just installed version 2.3.3 on Arch Linux, and it appears that I may be missing a required font because the interface is showing code points instead:

I am using LXQT, but I do have wxWidgets libraries for GTK 2 and GTK 3 installed. I have run lxappearance to set GTK preferences and everything appears like it should be working. Other GTK based applications (like Chromium, and the Erlang observer app) appear as you would expect.

I have attached the output of fc-list on my system showing the available fonts.

Any assistance is greatly appreciated, thank you.
font-list.txt (348 KB)

Is this the first time that Audacity has been installed on this machine?

If you open “Edit menu > Preferences > Interface”, is that readable?
If it is, what language is selected?

Hi Steve -

I appreciate your response. Yes, this is the first time that I installed Audacity. I used the following command to install it:

sudo pacman -S audacity

The language selected was “System”, so I switched it to “English”. Unfortunately, the result is the same. Note that other UI elements are readable, such as the input driver selection (“ALSA”). There’s something different about the recording levels and other UI elements that are showing code points.

I took a screenshot after starting audacity with the following command line:

GDK_SCALE=2 GDK_DPI_SCALE=0.5 GTK_THEME=Adwaita:dark audacity


I’ve never seen this problem with Audacity. As far as I’m aware, Audacity does not have any specific requirements for fonts, at least nothing unusual.

Is your computer’s default language English? Nothing special about how the locale is set up?

Are the permissions correct for all of your fonts?

Is this a new installation of Arch and/or LXQT?
If so. have you tried many other applications yet?


Have you set up your locale?

Here’s my /etc/locale.conf:

# /etc/locale.conf -  Language configuration for Arch Linux
# See 'man 5 locale.conf' for more details


and my /etc/locale.gen uncommented entries:

# Configuration file for locale-gen
# lists of locales that are to be generated by the locale-gen command.
# Each line is of the form:
#     <locale> <charset>
#  where <locale> is one of the locales given in /usr/share/i18n/locales
#  and <charset> is one of the character sets listed in /usr/share/i18n/charmaps
#  Examples:
#  en_US ISO-8859-1
#  en_US.UTF-8 UTF-8
#  de_DE ISO-8859-1
#  de_DE@euro ISO-8859-15
#  The locale-gen command will generate all the locales,
#  placing them in /usr/lib/locale.
#  A list of supported locales is included in this file.
#  Uncomment the ones you need.
en_GB.UTF-8 UTF-8  
en_GB ISO-8859-1
en_US.UTF-8 UTF-8  
en_US ISO-8859-1

You need to run locale-gen (as root) after modifying this file and it’s a good idea to logout and login again for the previous file changes.


Looks OK, but to confirm, what do you get if you enter in a Terminal window:


Hi everyone -

I posted a reply yesterday stating that I tracked down and fixed the issue, but it either got lost or has not yet been approved.

Yes, setting up a locale is one of the first things you do when installing Arch -

$ locale

The short of it is that I looked at the Audacity source code and noticed that the wxFont selection specifies a “Swiss” font. Running this command…

fc-match swiss

…returned an installed font in a PFA file. I copied the fonts from my Windows 10 partition, and the “Swiss” font is now this:

$ fc-match Swiss
verdana.ttf: "Verdana" "Regular"

As you can see, it is correctly displayed.

There are no posts waiting for approval, so it must have somehow got lost.

Thanks for posting the solution.

It seems the font that matches on my system is DejaVu Sans. Maybe many Linux distributions install this font.

ATB, Neil

Most operating systems have a sans serif font that they use when “swiss” is called for. On Windows it is usually Helvetica. On Ubuntu / Debian I think it is normally DejaVu Sans.

I have the full set of Noto fonts installed, so you would think that “Noto Sans” would match for Swiss, but apparently it doesn’t /shrug