Missing drop downs

I am a little embarrassed to post this, but once again the middle two of the four drop downs on Audacity are missing. I posted this issue last year, and the advice I received worked. I was advised to go to “Windows Settings app - System - Sound and check the Input devices section.” But this time the error box says “no input devices found” I have a newer Win 10 computer, and have no explanation why things stopped working again.
Am using Audacity 3.1.3.

Thanks in advance for your help

I assume that your new computer does have an audio device?

Assuming that it has, the first thing to try is:

  1. Reboot the computer
  2. Launch Audacity (don’t open any other apps)

Computer worked several months ago, but drop downs are now missing for some reason. Am not sure what you mean by an “audio device” .

I don’t mind being “spoon fed” and I admit I know very little about computers and need step by step instructions

What is your computer? (Make and model)

Have you tried rebooting as suggested?

Win 10, Dell PC, Optiplex 7010. And I have now rebooted twice - no change.

Are you able to play (and hear) audio from YouTube? If so, how do you do that? Headphones plugged into the front panel?

When I go to youtube, I click on a site that plays music, and music comes out of the speakers connected to my computer, which is what is supposed to happen, I imagine. The speakers are connected to the mini stereo jack in the back of the computer.

Do you have a computer microphone? If so, try testing the mic input as described here: https://support.microsoft.com/en-gb/windows/how-to-set-up-and-test-microphones-in-windows-ba9a4aab-35d1-12ee-5835-cccac7ee87a4

If you don’t have a computer mic, try connecting a line level device (such as a CD player) to the line in socket on the back of the computer, and test in the same way.

An external mic, and also the output from a walkman plays music thru the computer, and out thru the speakers.

OK, that all sounds good.
Next you need to give Audacity permission to access the microphone (Microsoft use the word “microphone” to mean any / all audio recording).
See: Why can’t I record in Windows?

I went to -Settings - system - sound, and the box says “no input devices found”

I clicked on the Win hyper text “why can’t I record in Windows” , and that led me back thru the same circle I have been traveling all morning.

There was also an option that says “test your microphone”. I clicked on it, and after a few seconds, I heard a BEEP in the speakers, and the test said it could find no issues.

Also I went to " Sound Devices" and under the heading “input Devices” there is a huge blank space.

This computer used to work well with Audacity, but something went kerflooey, and I am out of patience. Will find another recording program

See the text in the green box: FAQ:Recording - Troubleshooting - Audacity Manual

the green box suggests I follow the steps and click on "settings -privacy- microphone. then click on "allow apps to access microphone, but they are all already clicked “ON.” Then I re booted again, and there is no change.

I’ve come to the end of my list of “easy solutions”.

You could check that the latest and correct version of the “Realtek” drivers are installed. The official drivers from Dell are available here: https://www.dell.com/support/home/en-uk/product-support/product/optiplex-7010/drivers