Missing Audio Data Block File(s)

Yikes! What the @#$% caused this!!!

I’ve read some of the other messages, but either I’m unable to understand if there was ever a fix or what the heck is going on? I had all my files saved happily in a directory on my hard drive. I didn’t move them at all. I did copy and paste them BACK INTO the same directory and renamed the copy to something different, as I wanted to preserve my RAW files. I also copied and renamed the aup directory and its files. Now I cannot open the original files NOR the copied versions – again – ALL HAVE REMAINED IN THE SAME DIRECTORY. I had closed and reopened them at least once – then all of a sudden they lose their pointers to the audio files – I GUESS!!!

I’ve spent HOURS editing a couple of files and now I am unable to access them to complete! PLEASE . . . tell me what I’m doing, not doing, should be doing . . . whatever! (Koz - in case you get this – I’m really concerned about this. I’m working on a REAL project!)

Operating System: Windows XP Pro
Audacity Version: 2.1.2

Sure hope I don’t have to start all over – AGAIN! :slight_smile:

Sheila Q.

AUP is a text file. It’s semi-English computer instructions what to do with all that stuff in the _DATA folder.

Open one of them in a text editor and read the first few lines. This is a graphic example of what it looks like (your mileage may vary).

Look for the line that says projname=".

It is required that you put the AUP and the _DATA filenames back to that name. You may not change either of those names outside of Audacity. Backups can be made by copying the AUP and the _DATA to a separate directory or drive without changing the names.

Next time Export a WAV (Microsoft) sound file as a backup.

The specific error sometimes happens when you close Audacity before it gets done writing the work to the drive. The scenario is someone who finishes a job and slams their laptop shut just a little too soon.

I don’t know there is a solution. It usually means there’s pieces of the show that just aren’t there any more.

I read through that three times and I can’t visualize what you did. You copied…what?


We have a no-win condition. Windows XP is now a security hazard if it ever touches the internet. Don’t let it touch the internet.

The only option is The Horror That Is Windows 10.

Or convert to Mac.


I do have a visual aid. This is a normal Project.


Audacity used to default to a system where it would leave associated sound files splashed all over your machine. It doesn’t do that any more. Unless you changed it, Audacity is complete in one file and one folder. So no more pointers to external files.

Unless you want that. Audacity can be very fast and efficient with external sound files. Many people couldn’t manage the spray of files, however.


Windows XP. Are you running out of hard drive space? When was the last time you optimized your drive? WinXP will not do that automatically and the drive will slowly get rattier and sloppier.


Hi Koz!! :slight_smile:

Great to hear from you! It’s been a little bit. :slight_smile: Oh, before I start, I’m only using my Windows XP desktop for doing my edits – not recording. It’s just in a more comfortable part of my apartment. :slight_smile: In hopes of helping you better understand what I did, I’ll give it another shot – OH! And thanks for the text file tidbit. I’ll give that a try. OK, I’ve always been used to being able in applications, that if I wanted a second copy of a file, I could either do a second “Save As” and name it something meaningful. Or, I could “copy” the original file, paste it back into the same or a different directory, and just rename it – thus either way – I had a second working copy – or a backup. My intent with Audacity was to enable me to keep the RAW recording and the MASTERED copy separate.

Audacity obviously does not allow for that. I had already tried doing a second “Save Project As”, but it would always tell me I was working only with an audio file and it couldn’t save it as a new project. I never was able to open a previously saved “project” – (i.e. book chapter), or maybe I wasn’t going about it right. If I drilled down in the .aup directory, it showed a bunch of separate audio files.

So, what I had done was, within the directory on my hard drive where I had my original recordings, I tried doing the copy/paste on both the project directories, and audio file that was hanging outside the project directory, and pasted them back into the same location, then renamed both to match. After I did that, then I got the "Missing Audio Data Block File(s) error on both the copied/pasted file(s) AND on the originals – and all I had done with the originals was copy them. It just seems weird.

I’ll see if I can do the text file thing and get things somewhat back in order before moving ahead. As always, thanks so much for your input and help. Hope you’re having a terrific day!! I’ll let you know if I get your recommendation to work. Take care!


Sorry Koz . . . didn’t see your newest two messages as I was replying to your earlier ones. No, I agree that it’s a good thing not to have the sound files all over the place. As for XP machine, I optimized just last week. Plus, I still have 193GB of space left on its hard drive. But, again, I’m only using it for editing – transferring my files via a thumb drive from my Windows 7 laptop.


Just a ray of sunshine before I have to drop out for a while. If you Did Something when you saved the project from the edit, then all your saves and backups are damaged.

Do you have the WAV (Microsoft) you Exported from the original performance? At least you don’t have to do that again.


Dueling Posts. I need to read through that.


Hey Koz,

Hmmmmm . . . I tried to find the text file you mentioned, but in all of my project _Data folders, there are only audio files. I have my system set to show hidden files, but . . . there is nothing in any of the project directories that show as that kind of text file. What am I missing? :slight_smile:


Ha! Ha! Ha!

I have the originals on my laptop and thumb drive . . . just without the edits. So I DOOOOO have them. It’s quite possible I got hasty in closing a file. Would be nice is Audacity would show you a “saving progress” bar then if it takes so long to save a project. I will start doing the WAV file thing. Thanks for the tip. :slight_smile: I will forge ahead and see what I come up with. :slight_smile: Hey, have super rest of your day!


I tried to find the text file you mentioned

Close. The AUP file is text. It makes use of a little known property of computer files that under certain circumstances you’re allowed to scramble file extensions. It is totally a text file that doesn’t happen to end in .txt.

Right-click on the AUP file > Open With > List Of Programs > NotePad (whatever it is in Windows). Do not allow the program to save anything. Just look.

My illustration is from an earlier Audacity. Attached is from Audacity 2.1.2. It’s harder to see, but dig a bit and it says projname=“auptest_data” . I called my fake show AUPTEST.

Again casting our gaze back to the original problem, didn’t Audacity volunteer to open the show anyway and substitute silence for the missing bits? I thought it normally did that.

I will admit to being an Audacity Project Virgin (so to speak). I have never used one in production. I have always used WAV (Microsoft) for everything. Be clear my job is shooting, not editing. After a shoot, I pack the whole thing up and send it upstairs to the grownup editors to chew on.

Screen Shot 2016-08-16 at 13.39.56.png

Hi Koz,

Well, THAT makes more sense! :slight_smile: I’ll definitely try the “right click” thing . . . but likely tomorrow. I think my brain is full for the day, today. :slight_smile: And, yes, Audacity gives you the “silence” options, but I am not well-versed enough in the software to choose something other than the “get out safely” option. :slight_smile: Perhaps I should just get adventurous some day and play around with it. :slight_smile:

Not so the concern that I had before. I think I may have caught the folks, for whom I was doing the project for, in a bit of a “plagerism” (spell?) snafoo. They/we cancelled the contract and I am much happier with having done so. Something just isn’t right there, and I’m glad to be out of it.

But, I’ll continue to pursue the things you suggested, as I know they will come in handy going forward. As always, thanks so much for your help and support. I learn something new every time you and I engage in a forum “conversation”. :slight_smile: Take good care and have a wonderful evening!


Perhaps I should just get adventurous some day and play around with it.

There is another poster who is hanging at the top of the forum waiting for an elf to tell him it’s “safe” to replace all the errors with silence. That makes more sense now. The dialog actually says that, right?

Are you in any position to post the broken…what, chapter? You may be holding development gold there. Don’t delete those files—or cover them up.

This is not a raw capture, right? This happened in the course of heavy editing.


It only does that if it is going to take more than a few seconds. It always tell you in a message at the bottom when the project has been saved, but the message is replaced if you move the mouse in the waveform.

Audacity can do project saves at different stages to different names. File > Save Project As… . You should not do any renamings and copyings by hand.

See http://manual.audacityteam.org/man/audacity_projects.html.


Hi Gale (and Koz),

Thanks for the explanation on the “saving” thing. Apparently I did get in a hurry and perhaps closed the file too soon. I’ll be move vigilant. :slight_smile: Koz, sorry to say, I did delet the corrupt files. I’m sure I could always recreate them though. I have several other copies. And, no, this happened BEFORE any editing. I did it when I was attempting to save the raw file before I applied any effects.

I truly do think it was user error and . . . well, HASTE. :slight_smile: I’ll play with it some tomorrow and see if I can confirm that. Much thanks to you both for all your help! I’m having fun with it all and learning a lot!