Missing and orphan audio blocks in all of my recordings

Version 2.2.2 Windows 10 HP Envy laptop.
So I was going to remaster songs that I recorded 4 years ago with better music mastering knowledge unlike back then when I recorded added some effects and quickly put together but I digress…

I opened every single recording to a Missing file block error… so I would continue by saving the log file and checking the second selection for this session only. Then I got the orphan block message and saved that log as well. I curiously opened the log file and compared both the missing and orphan files… I only checked a few but they were the same. I even opened the raw files into audacity and they belonged to the project. Mind you this never ever happened before.

I may have been naive at the art of engineering back then and now to a certain extent but I know how to use the save functions of programs. I have all my data in the same folder as I did when I first started the projects. I did change laptops 3 years ago but I moved everything off of the old hard drive onto the new one…I didnt rename or change anything and it worked fine then. Heck I was able to remaster one song back in December with no issues (except I forgot to flat line the hi hat taps used like a metronome in a non drum part) So today I go to correct that and it said I had missing and orphan files when it didn’t before.

I like the ease of use of this program but with the issues with downloading version 2.3.0 and now this putting me in a tough spot financially as I may have to buy a program. I do clean my laptop regularly including disabling services and apps I hardly or don’t use. My hard drive is far from even being half full. When it comes to my laptop Im very ocd in keeping it running well. But for the life of me I don’t know why it’s not recognizing the orphaned files as the same files as the missing ones. :imp:

Do you have a small project that this problem occurs with? (Check the size of the “_data” folder. What’s the smallest one you have?).

Do you know how to make a ZIP file?

I’ll have to check later…I work overnights and I just got off of work. I will return and return my findings

If you zip your smallest damaged project, let us know the file size. If it misses the forum size restriction we may have other ways to get it.

You may have gold there. When this happens to other people, they’re usually doing a bunch of things wrong and it’s rough to split all the damage into cause and effect. You seemingly weren’t doing anything wrong and yet your show went into the mud.

Two things have to happen. Obviously, the blocks and snippets have to actually be there, but the AUP file has to know to go looking for them, too. That’s why we want the whole project.


Well when I got home this morning I opened a project I had done and havent touched in 4 years. It opened up with having orphan files…like over 300 of them. and I know it didn’t have this warning before as I would have gotten on it then like I am now. I did notice in every log that the files loaded in ffmpeg failed to load initially. I uninstalled ffmpeg, re downloded it then reinstalled it…to no avail. Then to add insult to injury I decided to add a final guitar part to a new project… Successful recording. However when I went to save project it came up with a new problem… Message stated It couldnt write the file to disk the reason was either the disk was write protected or it was full…now thats funny as I have 463 gb free of 665 gb. So I quickly saved each track as a wave. Uninstalled and reinstalled Audacity…nada. Personally I believe when I Downloaded and installed 2.3.0 it corrupted a registry file or something. COnventional uninstalls still leave residual fies behind . I am calling it quits with this program since now realizing this is a DAE and not a DAW (even though you will find people in the forum and over the internet say it’s a DAW) This program is great for podcasts and other apps that use few tracks.

When writing posts, please include occasional paragraph breaks so that it easier for others to follow what you are trying to say.

There are a couple of common reasons why this can occur.

  1. On Windows, file names and file paths MUST follow Microsoft’s rules: Naming Files, Paths, and Namespaces - Win32 apps | Microsoft Learn
    The most common problem here is the inclusion of “special” characters in the file name.

Although Microsoft’s rules are quite complex, the easy, and reliable rule (which works on Windows, Mac and Linux), is to use the following lower case characters only:
a to z, 0 to 9, hyphen (“-”, but NOT the dash character “—”) and underscore (“_”).

Upper-case (capital letters) are generally OK, but some sequences of upper case characters are invalid on Windows because they are reserved keywords (such as CON, PRN, AUX, NUL, COM1, COM2…). Upper case characters may also cause broken links for files uploaded to the Internet.

Spaces are generally OK, but may cause broken links for files uploaded to the Internet.

The backslash ("") character should never be used in a filename.

  1. Windows has a rather complicated system for handling file permissions, and disallows writing to some locations. This particularly effects system directories, and some external drives.
    The safe location is anywhere within your “home” user-space. The computer user’s “Documents”, “Pictures”, “Music”, “Video” and “Download” folders should be fully accessible for the current logged-in user.

Audacity doesn’t use the registry, other than offering to add a file association for AUP files. All other settings are written to configuration files rather than the Windows registry. The configuration files are written to: *Users<username>\AppData\Roaming\Audacity*

Yes, Audacity is a multi-track audio recorder and editor, not a “real-time digital audio workstation”. However, it can be used with large projects. I used to regularly use it for projects with 20 or more tracks. I think the largest project I ever worked on in Audacity was 83 tracks, and about 20 minutes long.

I am calling it quits with this program

OK, but before you do, try and get that corrupted project to us. We would really like to find out why the files are doing this.