I have windows 10 and audacity 2.2.2 - when I record I voice files in the right channel over the music in the left channel I get an echo in the voice files. I use to be able to fix that in my older windows 8.1 but making making sure I had the mike shown in the front - when I change that in the audacity 2.2.2 all I get is a distorted voice file. When I change it back to another mike input I get a clear recording but with a very back echo - it should like i’m in a deep well - HELP

Make sure you’ve selected the correct [u]Recording Device[/u] where the mic is plugged in. (Don’t record from Stereo Mix or Loopback.)

And, make sure [u]Windows “Enhancements”[/u] are turned off.

If that doesn’t help, tell us what microphones and any other equipment you’re using and how everything is connected.