Migration from Win 7 to Win 8 problem

This looks like a path problem and maybe this is a new “feature” in Win 8.

I use the Task Scheduler to record from NPR web sites using Audacity. It works in Win 7 but the export/import to Win 8 doesn’t. When the scheduler is instructed to do anything with Audacity, I get the request “Who do you want to open this file?” then it shows a list of programs. Audacity is there at the top of the list. When I click it, Audacity opens.

In earlier versions of Win, there was that option to allow the selected program to be applied for future requests of this type.

This may be more of a Win problem and should be asked in a different forum but I figured I would ask it here first to see if someone here has already worked out something similar.

I use the Task Scheduler to record from NPR web sites using Audacity.

Actually, that’s not what you’re doing. You’re not live recording the streaming show. That would have worked. You’re downloading posted files. I do that with one show each week. Downloading and opening runs into security issues. I bet that’s where your script fails.

iTunes scheduling seems to be OK with that. You may be able to use iTunes for Windows to get this to work.


To my knowledge, I am recording streaming audio. It is recorded according to their broadcast schedule. It may have been previously recorded but it is the same as if I had my radio in my truck on and listening to the same station. It is not a podcast nor is it downloaded. All News breaks, time and date announcements, and weather alerts are recorded and correct timewize.

but the export/import to Win 8 doesn’t.

Then I’m confused. Live recording is not part of the Audacity Import and Export system — until you export the show later. Koz

Sorry for the confusion. I am not importing the music, rather the commands to control Audacity. I had the running in Task Scheduler WIn7 and exported them to a memory stick. I then used that stick to import the files/commands into that task Scheduler of the Win8 machine.

Again, this may not be an Audacity problem, rather I ask it here in case someone might have suggestions.
Right now, Win8 does not seem to recognize a command line instruction to invoke Audacity. It looks a lot like a path problem from Win3.1 DOS.

I do have this posted in the Microsoft Forum but they seem to be all confused…

Double-click the task in Task Scheduler to look at the task properties. Are you running with highest privileges as the correct user?

Is Win 8 a 64-bit computer and was Win 7 32-bit? If so, you need to change the path to Audacity to Program Files (x86).

Have you posted the task’s XML file on the Windows forum you’re asking on?


See the continuation of this at https://forum.audacityteam.org/t/task-scheduler-no-longer-talks-to-audacity/35873/1